summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarel Kočí2017-01-06 15:24:09 +0100
committerKarel Kočí2017-01-06 15:28:04 +0100
commit44eb2870195e9ef14ea870985657d5c3838debf1 (patch)
tree0c8abee6990ae7377afdf508d90dc766d3a86e2a
parent1a587a652d1fb54a9a115606905a76ca28f0840c (diff)
downloadaur-44eb2870195e9ef14ea870985657d5c3838debf1.tar.gz
lockdev bug is fixed so remove memo about it
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--known-lockdev-bug.patch31
3 files changed, 8 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db270348b8cf..4330d04cbc91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ttysterm
pkgdesc = Simple serial terminal
pkgver = 20160921
- pkgrel = 1
+ pkgrel = 2
url = https://rtime.felk.cvut.cz/gitweb/sojka/sterm.git
arch = i686
arch = x86_64
@@ -10,10 +10,8 @@ pkgbase = ttysterm
depends = lockdev
source = ttysterm::git://rtime.felk.cvut.cz/sojka/sterm.git
source = Fix-install-strip.patch
- source = known-lockdev-bug.patch
md5sums = SKIP
md5sums = e37c9b06de817993830efe9e277e740c
- md5sums = 5df1b7923840120638c8a5ee39ed9118
pkgname = ttysterm
diff --git a/PKGBUILD b/PKGBUILD
index f6828f2c9dfd..753b70afc1d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karel Koči <cynerd@email.cz>
pkgname=ttysterm
pkgver=20160921
-pkgrel=1
+pkgrel=2
pkgdesc="Simple serial terminal"
arch=('i686' 'x86_64')
url="https://rtime.felk.cvut.cz/gitweb/sojka/sterm.git"
@@ -10,11 +10,9 @@ depends=('lockdev')
makedepends=('git')
#changelog="debian/changelog"
source=("$pkgname::git://rtime.felk.cvut.cz/sojka/sterm.git"
- "Fix-install-strip.patch"
- "known-lockdev-bug.patch")
+ "Fix-install-strip.patch")
md5sums=('SKIP'
- 'e37c9b06de817993830efe9e277e740c'
- '5df1b7923840120638c8a5ee39ed9118')
+ 'e37c9b06de817993830efe9e277e740c')
prepare() {
cd "$pkgname"
@@ -22,16 +20,14 @@ prepare() {
git reset --hard $pkgver
# Fix install strip
patch -i $srcdir/Fix-install-strip.patch
- # Document known bug with lockdev and Systemd
- patch -i $srcdir/known-lockdev-bug.patch
}
build() {
- cd "$pkgname"
- make
+ cd "$pkgname"
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir/" PREFIX="/usr" install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
}
diff --git a/known-lockdev-bug.patch b/known-lockdev-bug.patch
deleted file mode 100644
index e4d7f2f357de..000000000000
--- a/known-lockdev-bug.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From bf776a6a38a79f3518b7a5f8866d789aa377e467 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <karel.koci@nic.cz>
-Date: Mon, 5 Dec 2016 07:54:27 +0100
-Subject: [PATCH 2/2] Add documentation about known bug with lockdev to man
-
----
- sterm.man | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/sterm.man b/sterm.man
-index 3a77f2a..07356f6 100644
---- a/sterm.man
-+++ b/sterm.man
-@@ -90,7 +90,13 @@ Any other input in the command mode raises an error and causes the
- program to exit.
-
- .SH BUGS
--No known bugs.
-+.I dev_lock(): No such file or directory
-+.RS
-+This is caused by known bug with lockdev and Systemd on Archlinux. After boot
-+there is no directory '/var/lock/lockdev'. You have to create it after every boot
-+with:
-+ \fBsudo (mkdir /var/lock/lockdev; chown root:lock /var/lock/lockdev)\fR
-+.RE
-
- .SH SEE ALSO
- .BR minicom (1),
---
-2.10.2
-