summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2015-06-14 02:23:18 -0300
committerVinícius dos Santos Oliveira2015-06-14 02:23:18 -0300
commitdeef78f8c1cbb3644d59032886bdc42ecea36814 (patch)
tree0d9d787f467764c5cb45a1a83dffe4861ff822a1
downloadaur-deef78f8c1cbb3644d59032886bdc42ecea36814.tar.gz
Genesis commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af8f7ca42892
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tufao0
+ pkgdesc = An asynchronous web framework for C++ built on top of Qt
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://github.com/vinipsmaker/tufao
+ arch = i686
+ arch = x86_64
+ license = LGPL2
+ makedepends = cmake
+ depends = qt4
+ source = https://github.com/vinipsmaker/tufao/archive/0.8.2.tar.gz
+ md5sums = 24f6d66a987c797fab9506ef8f480475
+
+pkgname = tufao0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2818da09bbd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+pkgname=tufao0
+pkgver=0.8.2
+pkgrel=1
+pkgdesc="An asynchronous web framework for C++ built on top of Qt"
+arch=('i686' 'x86_64')
+url="https://github.com/vinipsmaker/tufao"
+license=('LGPL2')
+depends=('qt4')
+makedepends=('cmake')
+source=("https://github.com/vinipsmaker/tufao/archive/${pkgver}.tar.gz")
+md5sums=('24f6d66a987c797fab9506ef8f480475')
+
+build() {
+ mkdir "${srcdir}/tufao-${pkgver}/build"
+ cd "${srcdir}/tufao-${pkgver}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+
+ cd "${srcdir}/tufao-${pkgver}/tools/pluginserverconfigeditor"
+ mkdir build
+ cd build
+ qmake-qt4 ..
+ make
+}
+
+package() {
+ cd "${srcdir}/tufao-${pkgver}/build"
+ make DESTDIR="$pkgdir" install
+
+ cd "${srcdir}/tufao-${pkgver}/tools/pluginserverconfigeditor/build"
+ install -D tufao-routes-editor "$pkgdir/usr/bin/tufao-routes-editor"
+}