summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2023-07-17 12:12:56 -0300
committerDanilo J. S. Bellini2023-07-17 12:23:57 -0300
commit42fcc9ceb5a4408c4718db61cc384462e8362ef8 (patch)
tree2e7f21a110e51aa65e8e7f9112ce2f12d30437b0
parent7a7053f6d11037ec72509e8eb4fafedf606bdb7b (diff)
downloadaur-42fcc9ceb5a4408c4718db61cc384462e8362ef8.tar.gz
v1.2.12-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa14e77e8ec8..cd5dfd0f7fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = tuiview
pkgdesc = Lightweight raster GIS viewer and attribute table writer
- pkgver = 1.2.9
+ pkgver = 1.2.12
pkgrel = 1
url = http://tuiview.org
arch = x86_64
license = GPL2
+ depends = python-setuptools
depends = python-numpy
depends = python-gdal
depends = python-pyqt5
optdepends = kealib: KEA raster file format support
options = !emptydirs
- source = https://github.com/ubarsc/tuiview/archive/tuiview-1.2.9.tar.gz
- sha256sums = 544c34b02f64688a2b46f345c6038964ef0da2cec0ca8a666953e11a0b0b4d0d
+ source = https://github.com/ubarsc/tuiview/archive/tuiview-1.2.12.tar.gz
+ sha256sums = 2b562f41bcfa8bdcfb9cba484f3752a25525258d34a1d7f9cf0843cc759d7485
pkgname = tuiview
diff --git a/PKGBUILD b/PKGBUILD
index 18c498680aa6..21ccf80a6681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,26 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('tuiview')
-pkgver=1.2.9
+pkgver=1.2.12
pkgrel=1
pkgdesc="Lightweight raster GIS viewer and attribute table writer"
arch=('x86_64')
url='http://tuiview.org'
license=('GPL2')
-depends=('python-numpy' 'python-gdal' 'python-pyqt5')
+depends=('python-setuptools' 'python-numpy' 'python-gdal' 'python-pyqt5')
optdepends=('kealib: KEA raster file format support')
options=(!emptydirs)
source=("https://github.com/ubarsc/tuiview/archive/tuiview-$pkgver.tar.gz")
-sha256sums=('544c34b02f64688a2b46f345c6038964ef0da2cec0ca8a666953e11a0b0b4d0d')
+sha256sums=('2b562f41bcfa8bdcfb9cba484f3752a25525258d34a1d7f9cf0843cc759d7485')
+
+prepare() {
+ cd "$srcdir/tuiview-tuiview-$pkgver"
+
+ # Fix entry points to import the module before calling "run"
+ sed -ri 's/:(.*)\.run/.\1:run/' setup.py
+
+ # Fix a relative import missing the leading dot
+ sed -i 's/minify_json/.&/' tuiview/pseudocolor.py
+}
package() {
cd "$srcdir/tuiview-tuiview-$pkgver"