summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2016-12-20 14:34:30 -0200
committerDanilo J. S. Bellini2016-12-20 14:34:30 -0200
commitaa98a87d9b46f061d93488bc50ccbd9b20785d8e (patch)
tree85515eacb00d0cb07ccacd8bea48303f07c03751
downloadaur-aa98a87d9b46f061d93488bc50ccbd9b20785d8e.tar.gz
v1.1.9-1
v"TuiView-$pkgver"-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c3d3f71dde8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tuiview
+ pkgdesc = Lightweight raster GIS viewer and attribute table writer
+ pkgver = 1.1.9
+ pkgrel = 1
+ url = http://tuiview.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = python2-numpy
+ makedepends = gdal
+ makedepends = python2-pyqt4
+ depends = python2-numpy
+ depends = gdal
+ depends = python2-pyqt4
+ options = !emptydirs
+ source = https://bitbucket.org/chchrsc/tuiview/downloads/TuiView-1.1.9.tar.gz
+ md5sums = 7d0fd3a03ebbe5bd6a2fd5e49f5b70ba
+ sha256sums = 41e706f0c2d821fa7c4e07b667a3455f466bf0c3579dac8a4ab118774fc1d6ed
+
+pkgname = tuiview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f90237606b0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+pkgname=('tuiview')
+pkgver=1.1.9
+pkgrel=1
+pkgdesc="Lightweight raster GIS viewer and attribute table writer"
+arch=('i686' 'x86_64')
+url='http://tuiview.org'
+license=('GPL2')
+makedepends=('python2-numpy' 'gdal' 'python2-pyqt4')
+depends=("${makedepends[@]}")
+options=(!emptydirs)
+_srcpath="TuiView-$pkgver"
+source=("https://bitbucket.org/chchrsc/$pkgname/downloads/$_srcpath.tar.gz")
+md5sums=('7d0fd3a03ebbe5bd6a2fd5e49f5b70ba')
+sha256sums=('41e706f0c2d821fa7c4e07b667a3455f466bf0c3579dac8a4ab118774fc1d6ed')
+
+prepare() {
+ # Updates the shebang in Python scripts for Python 2
+ find "$srcdir/$_srcpath" -name "*.py" \
+ -exec sed -i '1s/python\s*$/python2/' '{}' \;
+}
+
+package() {
+ cd "$srcdir/$_srcpath"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}