summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMateusz Maćkowski2020-04-22 17:37:05 +0200
committerMateusz Maćkowski2020-04-22 17:37:05 +0200
commit05809ecfb1bfe2f95d34d7ea1f4ffcabf5a89e80 (patch)
tree2874d773e7aba5dedb534f23bca2dc0f462f427a
downloadaur-05809ecfb1bfe2f95d34d7ea1f4ffcabf5a89e80.tar.gz
Initial commit, tundra 0.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..daf3a36f8af9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tundra
+ pkgdesc = MyAnimeList scrobbler
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://tundra.moe
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ depends = gtk3
+ depends = dbus
+ source = tundra-0.1.tar.gz::https://github.com/m4tx/tundra/archive/v0.1.tar.gz
+ source = https://raw.githubusercontent.com/erengy/anime-relations/2c55e0ce48462a75ca8680dc2a9828887aea1792/anime-relations.txt
+ md5sums = 1e3427b3cc4fc7f36afe673d02983eb7
+ md5sums = ec26a1895b54f4f7a03538e117354311
+
+pkgname = tundra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2772d8acadbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Mateusz Maćkowski <mateusz@mackowski.org>
+pkgname=tundra
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="MyAnimeList scrobbler"
+arch=('x86_64')
+url="https://tundra.moe"
+license=('GPL3')
+groups=()
+depends=('gtk3' 'dbus')
+makedepends=('rust')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/m4tx/$pkgname/archive/v$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/erengy/anime-relations/2c55e0ce48462a75ca8680dc2a9828887aea1792/anime-relations.txt")
+noextract=()
+md5sums=('1e3427b3cc4fc7f36afe673d02983eb7'
+ 'ec26a1895b54f4f7a03538e117354311')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cp "$srcdir/anime-relations.txt" "vendor/anime-relations/"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ return 0
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+ install -Dm 755 data/com.m4tx.Tundra.svg -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ install -Dm 755 data/com.m4tx.Tundra.desktop -t "${pkgdir}/usr/share/applications"
+}