summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMateusz Maćkowski2022-02-20 21:25:34 +0100
committerMateusz Maćkowski2022-02-20 21:25:34 +0100
commit320dae6e7046bd6af1fae7c1dca6463bfce73ce6 (patch)
tree034ec4ed5ef82322a7cdd2e71eecc49d46b54781
downloadaur-320dae6e7046bd6af1fae7c1dca6463bfce73ce6.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD50
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b8fd5abfa7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tundra-git
+ pkgdesc = MyAnimeList scrobbler (git version)
+ pkgver = 0.3.0.014070
+ pkgrel = 2
+ url = https://tundra.moe
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ depends = gtk3
+ depends = dbus
+ provides = tundra
+ conflicts = tundra
+ source = git://github.com/m4tx/tundra
+ source = https://raw.githubusercontent.com/erengy/anime-relations/master/anime-relations.txt
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = tundra-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d5ce118963b1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+anime-relations.txt
+src/
+tundra/
+pkg/
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7e860b7732d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Mateusz Maćkowski <mateusz@mackowski.org>
+pkgname=tundra-git
+pkgver=0.3.0.014070
+pkgrel=1
+epoch=
+pkgdesc="MyAnimeList scrobbler (git version)"
+arch=('x86_64')
+url="https://tundra.moe"
+license=('GPL3')
+groups=()
+depends=('gtk4' 'libadwaita' 'dbus')
+makedepends=('rust' 'git')
+checkdepends=()
+optdepends=()
+provides=('tundra')
+conflicts=('tundra')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git://github.com/m4tx/tundra"
+ "https://raw.githubusercontent.com/erengy/anime-relations/master/anime-relations.txt")
+noextract=()
+md5sums=('SKIP'
+ 'SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "tundra"
+ cp "$srcdir/anime-relations.txt" "vendor/anime-relations/"
+}
+
+build() {
+ cd "tundra"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ return 0
+}
+
+package() {
+ cd "tundra"
+ install -Dm 755 target/release/tundra -t "${pkgdir}/usr/bin"
+ install -Dm 755 data/moe.tundra.Tundra.svg -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ install -Dm 755 data/moe.tundra.Tundra.desktop -t "${pkgdir}/usr/share/applications"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -r target/locale "$pkgdir/usr/share/"
+}