summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricebal2018-11-20 18:11:57 -0600
committericebal2018-11-20 18:11:57 -0600
commita22a54b95a1bea761081b7e391ea3d51174dec90 (patch)
tree93190dfaea6efa41b7aa799d92f9b3e3e7dc276d
parentaaee2927cd598c453c94cb9329aff805b2f74eed (diff)
downloadaur-a22a54b95a1bea761081b7e391ea3d51174dec90.tar.gz
updated PKGBUILD and dependancies
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2238eec0be7..16d5c6cb7442 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = tuned-git
pkgdesc = Daemon that performs monitoring and adaptive configuration of devices in the system
- pkgver = 2.5.0.r6.ge32bd6b
+ pkgver = v2.10.0.r40.gb9e1316
pkgrel = 1
- url = https://fedorahosted.org/tuned/
+ url = https://github.com/redhat-performance/tuned
install = tuned.install
arch = any
license = GPL
makedepends = git
depends = ethtool
- depends = python2-configobj
- depends = python2-pyudev
- depends = python2-gobject2
- depends = python2-decorator
- depends = python2-dbus
+ depends = python-configobj
+ depends = python-pyudev
+ depends = python-gobject2
+ depends = python-decorator
+ depends = python-dbus
+ depends = python-dmidecode
optdepends = virt-what
optdepends = systemtap
provides = tuned
backup = etc/tuned/active_profile
- source = tuned-git::git://git.fedorahosted.org/git/tuned.git
+ source = tuned-git::git://github.com/redhat-performance/tuned
sha256sums = SKIP
pkgname = tuned-git
diff --git a/PKGBUILD b/PKGBUILD
index f6af3e61d03f..20511aaf39d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
-# Maintainer: Timothée Ravier < tim at siosm dot fr >
+# Maintainer: Wes Jackson < icebal dot 7 at gmail dot com >
# Contributor: Tom < reztho at archlinux dot org >
pkgname=tuned-git
-pkgver=2.5.0.r6.ge32bd6b
+pkgver=v2.10.0.r40.gb9e1316
pkgrel=1
pkgdesc='Daemon that performs monitoring and adaptive configuration of devices in the system'
arch=('any')
-url='https://fedorahosted.org/tuned/'
+url='https://github.com/redhat-performance/tuned'
license=('GPL')
-depends=('ethtool' 'python2-configobj' 'python2-pyudev' 'python2-gobject2'
- 'python2-decorator' 'python2-dbus')
+depends=('ethtool' 'python-configobj' 'python-pyudev' 'python-gobject2'
+ 'python-decorator' 'python-dbus' 'python-dmidecode')
optdepends=('virt-what' 'systemtap')
makedepends=('git')
provides=('tuned')
backup=('etc/tuned/active_profile')
install="${pkgname/-git}.install"
-source=("${pkgname}::git://git.fedorahosted.org/git/${pkgname/-/.}")
+source=("${pkgname}::git://github.com/redhat-performance/tuned")
sha256sums=('SKIP')
pkgver() {
@@ -32,9 +32,6 @@ package() {
mv "${pkgdir}"/usr/sbin/* "${pkgdir}"/usr/bin/
mv "${pkgdir}"/usr/libexec/tuned/* "${pkgdir}"/usr/lib/tuned/
rm -r "${pkgdir}"/run "${pkgdir}"/usr/sbin "${pkgdir}"/usr/libexec
-
- find "${pkgdir}"/usr/bin/ -type f -exec sed -i 's@#!/usr/bin/python@#!/usr/bin/python2@' {} \;
-
install -Dm 0644 "${srcdir}"/${pkgname}/tuned.service "${pkgdir}"/usr/lib/systemd/system/tuned.service
}