summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-03-29 22:43:55 +0200
committerChristopher Arndt2018-03-29 22:43:55 +0200
commit319d20767790fbcf96aa0ec143228814534fc468 (patch)
treef5fa587274947e280d37693eb36962b6ac11f164
downloadaur-319d20767790fbcf96aa0ec143228814534fc468.tar.gz
New package 'tunefish4'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD44
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..178e7fa994d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tunefish4-git
+ pkgdesc = An additive wavetable-based synthesizer VST plugin (git version)
+ pkgver = 4.1.0.r80.13bd685
+ pkgrel = 1
+ url = http://www.tunefish-synth.com/
+ arch = x86_64
+ groups = vst-plugins
+ license = GPL3
+ makedepends = git
+ depends = webkit2gtk
+ provides = tunefish4
+ conflicts = tunefish4
+ conflicts = tunefish4-vst-bin
+ source = tunefish4::git://github.com/paynebc/tunefish.git
+ sha256sums = SKIP
+
+pkgname = tunefish4-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eff59503e889
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+tunefish4/
+tunefish4-git-*.tar.xz
+tunefish4-git-*.src.tar.gz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31710d741fa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=tunefish4
+pkgname="${_pkgname}-git"
+pkgver=4.1.0.r80.13bd685
+pkgrel=1
+pkgdesc="An additive wavetable-based synthesizer VST plugin (git version)"
+arch=('x86_64')
+url="http://www.tunefish-synth.com/"
+# See https://github.com/paynebc/tunefish/blob/master/COPYING
+license=("GPL3")
+groups=('vst-plugins')
+depends=('webkit2gtk')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}" "${_pkgname}-vst-bin")
+source=("${_pkgname}::git://github.com/paynebc/tunefish.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ local version="$(git describe --tags | sed -e 's/RELEASE_\([^-]*\).*/\1/;s/_/./g')"
+ local revision=$(git rev-list --count HEAD)
+ local hash=$(git rev-parse --short HEAD)
+ echo $version.r$revision.$hash
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/src/tunefish4/Builds/LinuxMakefile/"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -dm755 "${pkgdir}/usr/lib/vst/tf4programs"
+ install -m755 src/tunefish4/Builds/LinuxMakefile/build/Tunefish4.so \
+ "${pkgdir}/usr/lib/vst"
+ install -m644 patches/tf4programs/* "${pkgdir}/usr/lib/vst/tf4programs"
+}
+
+# vim:set ts=2 sw=2 et: