summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2015-12-07 14:33:35 +0100
committerChristopher Arndt2015-12-07 14:33:35 +0100
commit18a5252f28d73243529c9cf2c70cba4c3bdf2832 (patch)
tree46f8db9372486d70992da8042a45e2c10f5f9018
downloadaur-18a5252f28d73243529c9cf2c70cba4c3bdf2832.tar.gz
Add new package tunefish4-vst-bin
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD29
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c6c6af94dc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tunefish4-vst-bin
+ pkgdesc = An additive wavetable-based synthesizer VST plugin
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = http://www.tunefish-synth.com/
+ arch = i686
+ arch = x86_64
+ groups = vst-plugins
+ license = GPL3
+ depends = alsa-lib
+ depends = glib2
+ depends = freetype2
+ depends = graphite
+ depends = mesa
+ source_i686 = http://www.tunefish-synth.com/downloads/tunefish-v4.0.1-linux32-vst24.tar.gz
+ sha256sums_i686 = 3f4e4c336db48ce9cf922704bb38f82960eef85dc9c0a7a989d5032a1902c7e4
+ source_x86_64 = http://www.tunefish-synth.com/downloads/tunefish-v4.0.1-linux64-vst24.tar.gz
+ sha256sums_x86_64 = 9595aad67134631700aec4c4f2c5ae255d025493b3432ca4148b8fafbd9a5d84
+
+pkgname = tunefish4-vst-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..11a95ea047d5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+tunefish-v*-linux*-vst24.tar.gz
+tunefish4-vst-bin-*.tar.xz
+tunefish4-vst-bin-*.src.tar.gz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ff686827e8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=tunefish4
+pkgname="${_pkgname}-vst-bin"
+pkgver=4.0.1
+pkgrel=1
+pkgdesc="An additive wavetable-based synthesizer VST plugin"
+arch=('i686' 'x86_64')
+url="http://www.tunefish-synth.com/"
+# See https://github.com/paynebc/tunefish/blob/master/COPYING
+license=("GPL3")
+groups=('vst-plugins')
+# glib2 and graphite are included, even if namcap thinks the dependencies are
+# already satisfied, but this is caused by the cyclic dependency
+# freetype <-> harbuzz
+depends=('alsa-lib' 'glib2' 'freetype2' 'graphite' 'mesa')
+source=()
+source_i686=("http://www.tunefish-synth.com/downloads/tunefish-v${pkgver}-linux32-vst24.tar.gz")
+source_x86_64=("http://www.tunefish-synth.com/downloads/tunefish-v${pkgver}-linux64-vst24.tar.gz")
+sha256sums_i686=('3f4e4c336db48ce9cf922704bb38f82960eef85dc9c0a7a989d5032a1902c7e4')
+sha256sums_x86_64=('9595aad67134631700aec4c4f2c5ae255d025493b3432ca4148b8fafbd9a5d84')
+
+package() {
+ install -dm755 "${pkgdir}/usr/lib/vst/tf4programs"
+ install -m755 "${srcdir}/${_pkgname}.so" "${pkgdir}/usr/lib/vst"
+ install -m644 "${srcdir}/tf4programs/"* "${pkgdir}/usr/lib/vst/tf4programs"
+}
+
+# vim:set ts=2 sw=2 et: