summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxgdgsc2015-06-12 20:18:59 +0800
committerxgdgsc2015-06-12 20:18:59 +0800
commite3499266c48148e8170a58a6929bf1a302218d14 (patch)
tree3e140bc42b4a290c0f7310ddfd39b454ee5ad520
downloadaur-e3499266c48148e8170a58a6929bf1a302218d14.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rwxr-xr-xTUNet.desktop10
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5ab49f3b63a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tunet
+ pkgdesc = Tsinghua University network authentication client for Linux.
+ pkgver = 1
+ pkgrel = 1
+ url = http://net.tsinghua.edu.cn
+ arch = i686
+ arch = x86_64
+ license = Unknown
+ depends = glib2
+ source = http://net.tsinghua.edu.cn/files/TUNet_linux.tar.gz
+ source = TUNet.desktop
+ md5sums = da737c2edd551cc259378eef3dff343b
+ md5sums = 55d1a040bc394e096fa4c81f43444458
+
+pkgname = tunet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f0fb7ef2455
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Maintainer:xgdgsc
+
+pkgname="tunet"
+pkgver="1"
+pkgrel=1
+pkgdesc="Tsinghua University network authentication client for Linux."
+arch=("i686" "x86_64")
+url="http://net.tsinghua.edu.cn"
+license=('Unknown')
+source=("http://net.tsinghua.edu.cn/files/TUNet_linux.tar.gz" "TUNet.desktop")
+md5sums=("da737c2edd551cc259378eef3dff343b" "55d1a040bc394e096fa4c81f43444458")
+depends=('glib2')
+
+package() {
+ cd "${srcdir}/TUNet_linux/"
+ mkdir -p "${pkgdir}/opt/TUNet"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ cp *.png "${pkgdir}/opt/TUNet"
+ cp tunet.ui "${pkgdir}/opt/TUNet"
+ if [[ $CARCH = i686 ]];then
+ cp TUNet "${pkgdir}/opt/TUNet"
+ sed -i 's|Exec=/opt/TUNet/TUNet64|Exec=/opt/TUNet/TUNet|' "${srcdir}/TUNet.desktop"
+ cp "${srcdir}/TUNet.desktop" "${pkgdir}/usr/share/applications/"
+ else
+ cp TUNet64 "${pkgdir}/opt/TUNet"
+ cp "${srcdir}/TUNet.desktop" "${pkgdir}/usr/share/applications/"
+ fi
+} \ No newline at end of file
diff --git a/TUNet.desktop b/TUNet.desktop
new file mode 100755
index 000000000000..ce47e9a4878f
--- /dev/null
+++ b/TUNet.desktop
@@ -0,0 +1,10 @@
+
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Name=TUNet
+Comment=TUNet
+Type=Application
+Exec=/opt/TUNet/TUNet64
+Icon=/opt/TUNet/log.png
+GenericName[en_US.UTF-8]=TUNet