summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-02-13 20:20:16 +0100
committerD3SOX2021-02-13 20:20:16 +0100
commitf148fdc743e7584f59660f73b535e83ac8cf455a (patch)
tree0fe3fccd9515d1c57ac657a6c645c3c6236038db
downloadaur-f148fdc743e7584f59660f73b535e83ac8cf455a.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edd6f2d7a5cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tunnelto
+ pkgdesc = Expose your local web server to the internet with a public URL.
+ pkgver = 0.1.12
+ pkgrel = 1
+ url = https://tunnelto.dev/
+ arch = any
+ license = MIT
+ makedepends = cargo
+ provides = tunnelto
+ conflicts = tunnelto
+ source = git+https://github.com/agrinman/tunnelto#tag=0.1.12
+ sha256sums = SKIP
+
+pkgname = tunnelto
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cf76afdf9fb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+pkgname=tunnelto
+pkgver=0.1.12
+pkgrel=1
+pkgdesc="Expose your local web server to the internet with a public URL."
+arch=('any')
+url="https://tunnelto.dev/"
+license=('MIT')
+makedepends=('cargo')
+conflicts=('tunnelto')
+provides=('tunnelto')
+source=("git+https://github.com/agrinman/$pkgname#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ # install binary
+ install -Dm 755 target/release/tunnelto -t "${pkgdir}/usr/bin"
+ #install -Dm 755 target/release/tunnelto_server -t "${pkgdir}/usr/bin"
+}