summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-08-30 18:19:03 +0800
committerChocobo12018-08-30 18:25:04 +0800
commit8461eb1d3f7ab0ce1777856fd71352110c201512 (patch)
tree139bbc0d102705502f600dd4c02e56b2609b2abc
downloadaur-8461eb1d3f7ab0ce1777856fd71352110c201512.tar.gz
newpkg: tunsafe 1.4_rc1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e630e244d1da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tunsafe
+ pkgdesc = High performance and secure VPN client that uses the WireGuard protocol
+ pkgver = 1.4_rc1
+ pkgrel = 1
+ url = https://tunsafe.com/
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ license = BSD
+ license = custom: OpenSSL
+ depends = gcc-libs
+ source = tunsafe-1.4_rc1-src.tar.gz::https://github.com/TunSafe/TunSafe/archive/cf92ac7a0c444ba4b31bdf9b1744705e6542d028.tar.gz
+ sha256sums = 7dc8bf8dd136d2db8f3032a215f300189064cc8772d28242be4ebd4c14c0262b
+
+pkgname = tunsafe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34b65890e491
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=tunsafe
+pkgver=1.4_rc1
+pkgrel=1
+pkgdesc="High performance and secure VPN client that uses the WireGuard protocol"
+arch=('i686' 'x86_64')
+url="https://tunsafe.com/"
+license=('AGPL' 'BSD' 'custom: OpenSSL')
+depends=('gcc-libs')
+source=("$pkgname-$pkgver-src.tar.gz::https://github.com/TunSafe/TunSafe/archive/cf92ac7a0c444ba4b31bdf9b1744705e6542d028.tar.gz")
+sha256sums=('7dc8bf8dd136d2db8f3032a215f300189064cc8772d28242be4ebd4c14c0262b')
+
+
+prepare() {
+ mv TunSafe-* "TunSafe"
+ cd "TunSafe"
+
+ sed -i "s/clang++-6.0/g++ $CXXFLAGS/;s/-lrt/-lrt $LDFLAGS/" "build_linux.sh"
+}
+
+build() {
+ cd "TunSafe"
+
+ ./build_linux.sh
+}
+
+package() {
+ cd "TunSafe"
+
+ install -Dm755 "tunsafe" "$pkgdir/usr/bin/tunsafe"
+ install -Dm644 "LICENSE.AGPL.TXT" "$pkgdir/usr/share/licenses/tunsafe/LICENSE.AGPL.TXT"
+}