summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Schweikert2015-06-16 13:42:47 +0200
committerFlorian Schweikert2015-06-16 13:42:47 +0200
commit00b870e41430d9fcc61956de408b99f35670f2b4 (patch)
tree1d4e93a9b0fbce6b767b8bb5f633fe3a78405829
downloadaur-00b870e41430d9fcc61956de408b99f35670f2b4.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
3 files changed, 62 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..63fe6310668f
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = tunslip
+ pkgdesc = tunslip and tunslip6 are tools to establish an IPv6 SLIP tunnel interface
+ pkgver = 2.7
+ pkgrel = 1
+ url = http://www.contiki-os.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = BSD
+ depends = glibc
+ source = https://github.com/contiki-os/contiki/raw/${pkgver}/tools/tunslip.c
+ source = https://github.com/contiki-os/contiki/raw/${pkgver}/tools/tunslip6.c
+ source = https://github.com/contiki-os/contiki/raw/${pkgver}/LICENSE
+
+pkgname = tunslip
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eda36015754c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tunslip
+ pkgdesc = tunslip and tunslip6 are tools to establish an IPv6 SLIP tunnel interface
+ pkgver = 2.7
+ pkgrel = 1
+ url = http://www.contiki-os.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = BSD
+ depends = glibc
+ source = https://github.com/contiki-os/contiki/raw/${pkgver}/tools/tunslip.c
+ source = https://github.com/contiki-os/contiki/raw/${pkgver}/tools/tunslip6.c
+ source = https://github.com/contiki-os/contiki/raw/${pkgver}/LICENSE
+ md5sums = ae0988ebf7f0dbf2cbb57f705d1ab5f1
+ md5sums = ca464a17fc509a72cc27edd74c194185
+ md5sums = b2276b027815460f098d51494e2ff4f1
+
+pkgname = tunslip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f825b564b3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Florian Schweikert <kelvan@ist-total.org>
+pkgname=tunslip
+pkgver=2.7
+pkgrel=1
+pkgdesc="tunslip and tunslip6 are tools to establish an IPv6 SLIP tunnel interface"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.contiki-os.org/"
+license=('BSD')
+depends=('glibc')
+optdepends=()
+source=('https://github.com/contiki-os/contiki/raw/${pkgver}/tools/tunslip.c'
+ 'https://github.com/contiki-os/contiki/raw/${pkgver}/tools/tunslip6.c'
+ 'https://github.com/contiki-os/contiki/raw/${pkgver}/LICENSE')
+md5sums=('ae0988ebf7f0dbf2cbb57f705d1ab5f1'
+ 'ca464a17fc509a72cc27edd74c194185'
+ 'b2276b027815460f098d51494e2ff4f1')
+
+build() {
+ gcc tunslip.c -o tunslip
+ gcc tunslip6.c -o tunslip6
+}
+
+package() {
+ install -D -m755 tunslip "$pkgdir/usr/sbin/tunslip"
+ install -D -m755 tunslip6 "$pkgdir/usr/sbin/tunslip6"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}