summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Schweikert2024-02-14 16:24:38 +0100
committerFlorian Schweikert2024-02-14 16:27:52 +0100
commita6653af82c0784a5051504640b8829a78082acd9 (patch)
tree36a51d07a78ad8ae719946c395d14ded66741696
parente5c29bf0b416ea6e9100a673a0df5a289f618428 (diff)
downloadaur-a6653af82c0784a5051504640b8829a78082acd9.tar.gz
chore: use Makefile
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9492aecbdf78..470737144def 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = tunslip6-ng
pkgdesc = tool to establish an IPv6 SLIP tunnel interface
pkgver = 4.9
- pkgrel = 1
+ pkgrel = 2
url = http://www.contiki-ng.org/
arch = i686
arch = x86_64
arch = armv7h
license = BSD
- depends = glibc
conflicts = tunslip
source = https://raw.githubusercontent.com/contiki-ng/contiki-ng/release/v4.9/tools/serial-io/tunslip6.c
+ source = https://raw.githubusercontent.com/contiki-ng/contiki-ng/release/v4.9/tools/serial-io/serialdump.c
source = https://raw.githubusercontent.com/contiki-ng/contiki-ng/release/v4.9/tools/serial-io/tools-utils.c
source = https://raw.githubusercontent.com/contiki-ng/contiki-ng/release/v4.9/tools/serial-io/tools-utils.h
source = https://raw.githubusercontent.com/contiki-ng/contiki-ng/release/v4.9/LICENSE.md
+ source = https://raw.githubusercontent.com/contiki-ng/contiki-ng/release/v4.9/tools/serial-io/Makefile
sha256sums = 64107f35495496e8a68c4ac5fffdbe71d5095b3435eb1f4360ae57b21431da00
+ sha256sums = 91dbbd45ed07fd4d76209016ced74a88ce9026766dca83d7daf681bb8bdbacf8
sha256sums = a53336f55b87382c3f13011b7c908fa1839316ecc2f4a595f7f7275c6fac82ae
sha256sums = b9e979dc1da9f485e731c0052f4c391d1d0c2f7d6ad13b97c8d8f75ad9b01dfd
sha256sums = cbdd874f179d9cb90784c20c81e91d1a6ad92facce008ff2306545deefb11255
+ sha256sums = f172c47e71db6717c48d8e97c39ba23c789aa076d602db9fea60562cd9c4c683
pkgname = tunslip6-ng
diff --git a/PKGBUILD b/PKGBUILD
index 0c01c444a249..2963bad320e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
pkgname=tunslip6-ng
pkgver=4.9
_branch=release/v${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc="tool to establish an IPv6 SLIP tunnel interface"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.contiki-ng.org/"
license=('BSD')
-depends=('glibc')
+depends=()
optdepends=()
conflicts=('tunslip')
source=(https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/tunslip6.c
+ https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/serialdump.c
https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/tools-utils.c
https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/tools-utils.h
- https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/LICENSE.md)
+ https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/LICENSE.md
+ https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/Makefile)
sha256sums=('64107f35495496e8a68c4ac5fffdbe71d5095b3435eb1f4360ae57b21431da00'
+ '91dbbd45ed07fd4d76209016ced74a88ce9026766dca83d7daf681bb8bdbacf8'
'a53336f55b87382c3f13011b7c908fa1839316ecc2f4a595f7f7275c6fac82ae'
'b9e979dc1da9f485e731c0052f4c391d1d0c2f7d6ad13b97c8d8f75ad9b01dfd'
- 'cbdd874f179d9cb90784c20c81e91d1a6ad92facce008ff2306545deefb11255')
+ 'cbdd874f179d9cb90784c20c81e91d1a6ad92facce008ff2306545deefb11255'
+ 'f172c47e71db6717c48d8e97c39ba23c789aa076d602db9fea60562cd9c4c683')
build() {
- gcc tools-utils.c tunslip6.c -o tunslip6
+ make
}
package() {