summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRohit Agrawal2015-06-12 12:36:20 -0400
committerRohit Agrawal2015-06-12 12:36:20 -0400
commitf65914d926fb944e39e8f2adcfb908c063bb3aa9 (patch)
tree821c0c086724154518e58ff6161a09a95fb044d9
downloadaur-tunsocks-git.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2559a1f247ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Fri Jun 12 16:34:56 UTC 2015
+pkgbase = tunsocks-git
+ pkgdesc = User-level IP forwarding and SOCKS proxy for VPNs that provide tun-like interface
+ pkgver = r3.19662d0
+ pkgrel = 2
+ url = https://github.com/russdill/tunsocks
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libpcap
+ source = git+https://github.com/russdill/tunsocks.git
+ source = git://git.sv.gnu.org/lwip.git
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = tunsocks-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8301a85c65b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Rohit Agrawal <rohit at rohitagr dot com>
+
+_pkgname=tunsocks
+pkgname=tunsocks-git
+pkgver=r3.19662d0
+pkgrel=2
+arch=('i686' 'x86_64')
+pkgdesc="User-level IP forwarding and SOCKS proxy for VPNs that provide tun-like interface"
+license=('BSD')
+depends=('libpcap')
+makedepends=('git')
+url="https://github.com/russdill/tunsocks"
+source=('git+https://github.com/russdill/tunsocks.git' 'git://git.sv.gnu.org/lwip.git' )
+sha1sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git config submodule.lwip.url "$srcdir/lwip"
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m0644 "$srcdir/lwip/COPYING" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+