summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake Howard2017-08-26 12:21:27 +0100
committerJake Howard2017-08-26 12:21:27 +0100
commitc2d4d47abaa9ef677d73664615b719b402e6b10f (patch)
tree611ee0d51ff01f2c3f5e01aa7a3b3d1d014b0bb6
downloadaur-c2d4d47abaa9ef677d73664615b719b402e6b10f.tar.gz
Publish initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3f40eae748d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tupload
+ pkgdesc = Capture screenshots and upload them using rsync
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/RealOrangeOne/tupload
+ arch = any
+ license = unknown
+ makedepends = python-pip
+ depends = python-setuptools
+ depends = rsync
+ depends = gnome-screenshot
+ source = tupload-1.0.0.tar.gz::https://github.com/RealOrangeOne/tupload/archive/1.0.0.tar.gz
+ sha512sums = e18fe97b985acc357b263f733cc5363f46132f56354df20a4868734df847d1cb4af385dd0dd85cf0e2f92a0b1549e4a3f47187cd8a3405f6787594e6c3fff0b9
+
+pkgname = tupload
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b3ede1e12f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Jake Howard <git+aur@theorangeone.net>
+pkgname=tupload
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Capture screenshots and upload them using rsync"
+arch=('any')
+url="https://github.com/RealOrangeOne/tupload"
+license=('unknown')
+depends=('python-setuptools' 'rsync' 'gnome-screenshot')
+makedepends=('python-pip')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RealOrangeOne/tupload/archive/$pkgver.tar.gz")
+sha512sums=('e18fe97b985acc357b263f733cc5363f46132f56354df20a4868734df847d1cb4af385dd0dd85cf0e2f92a0b1549e4a3f47187cd8a3405f6787594e6c3fff0b9')
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 tupload/config.json "$pkgdir"/etc/.upload
+}