summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Stengele2015-10-21 16:16:16 +0200
committerDennis Stengele2015-10-21 16:20:20 +0200
commit098a91ea83850094b25dbe3c0d69d82453808a33 (patch)
tree20cd43677100b0f4ff1774c2bc744cbdd7f320c3
parent90fdaa4844b3e1e649fae6613a0a32a095482921 (diff)
downloadaur-098a91ea83850094b25dbe3c0d69d82453808a33.tar.gz
Update to v3.0.00
Update checksums
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--tuptime.cron8
-rw-r--r--tuptime.service13
4 files changed, 8 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddf615e95bd1..ec07fe60c350 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = tuptime
pkgdesc = Report the historical and statistical running time of system
- pkgver = 2.1.00
+ pkgver = 3.0.00
pkgrel = 1
url = https://github.com/rfrail3/tuptime
arch = any
license = GPL
depends = python2
depends = cron
- source = tuptime-2.1.00.tar.gz::https://github.com/rfrail3/tuptime/archive/v2.1.00.tar.gz
- source = tuptime.service
- source = tuptime.cron
- sha256sums = 67b53feb2b7d4751045e6dff1b6fb7d3d3c8725b821c4b5eeb7b6b849f70c22c
- sha256sums = f7e106eb400fb3aa7ea5d0f8f5388d53cf38b054a9dae7e77268489c21e3a2f2
- sha256sums = 54675450a0c0f8d300a380b8ab61ca7845da7da0f7985694d086eda1eb77b81a
+ source = tuptime-3.0.00.tar.gz::https://github.com/rfrail3/tuptime/archive/v3.0.00.tar.gz
+ sha256sums = 8c3a2bc21e1fa1d30cd6f0e61aaeb6fa20461bfda2e13bfc77f67d302af70a08
pkgname = tuptime
diff --git a/PKGBUILD b/PKGBUILD
index 7182fa2401f7..7e1cdfc8b66b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dennis Stengele <d.stengele (at) derintendant (dot) de>
pkgname=tuptime
-pkgver=2.1.00
+pkgver=3.0.00
pkgrel=1
pkgdesc="Report the historical and statistical running time of system"
arch=('any')
@@ -18,18 +18,14 @@ backup=()
options=()
install=
changelog=
-source=(" $pkgname-$pkgver.tar.gz::https://github.com/rfrail3/tuptime/archive/v$pkgver.tar.gz"
- "tuptime.service"
- "tuptime.cron")
+source=(" $pkgname-$pkgver.tar.gz::https://github.com/rfrail3/tuptime/archive/v$pkgver.tar.gz")
noextract=()
-sha256sums=('67b53feb2b7d4751045e6dff1b6fb7d3d3c8725b821c4b5eeb7b6b849f70c22c'
- 'f7e106eb400fb3aa7ea5d0f8f5388d53cf38b054a9dae7e77268489c21e3a2f2'
- '54675450a0c0f8d300a380b8ab61ca7845da7da0f7985694d086eda1eb77b81a')
+sha256sums=('8c3a2bc21e1fa1d30cd6f0e61aaeb6fa20461bfda2e13bfc77f67d302af70a08')
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm755 "latest/tuptime" "$pkgdir/usr/bin/tuptime"
- install -Dm644 "$srcdir/tuptime.service" "$pkgdir/usr/lib/systemd/system/tuptime.service"
- install -Dm644 "$srcdir/tuptime.cron" "$pkgdir/etc/cron.d/tuptime"
+ install -Dm644 "latest/systemd/tuptime.service" "$pkgdir/usr/lib/systemd/system/tuptime.service"
+ install -Dm644 "latest/cron.d/tuptime" "$pkgdir/etc/cron.d/tuptime"
}
diff --git a/tuptime.cron b/tuptime.cron
deleted file mode 100644
index 0557cfc6eaa5..000000000000
--- a/tuptime.cron
+++ /dev/null
@@ -1,8 +0,0 @@
-# /etc/cron.d/tuptime: crontab entrie for tuptime update.
-
-# Execute tuptime each hour for avoid loss time if system don't shutdown correctly.
-# NOTE: Decrease the execution time for increase the accuracity.
-
-MAILTO=root
-
-*/5 * * * * root if [ -x /usr/bin/tuptime ]; then /usr/bin/tuptime -x > /dev/null; fi
diff --git a/tuptime.service b/tuptime.service
deleted file mode 100644
index 5fef7f4ca1cb..000000000000
--- a/tuptime.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Tuptime service
-After=local-fs.target
-Requires=local-fs.target
-
-[Service]
-Type=oneshot
-RemainAfterExit=true
-ExecStart=/usr/bin/tuptime -x
-ExecStop=/usr/bin/tuptime -xg
-
-[Install]
-WantedBy=local-fs.target