summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Stengele2018-02-11 21:28:27 +0100
committerDennis Stengele2018-02-11 21:28:27 +0100
commitcd60c5796be0dc4aa36d1c4af267c7c8abed6575 (patch)
tree9dfddc9bfcdfb88bffae4ca7a421f801d82602c5
parent6840f42ff832644dfdcc8d98fca99326d895ceed (diff)
downloadaur-cd60c5796be0dc4aa36d1c4af267c7c8abed6575.tar.gz
Update to version 3.3.3, change dep to python3 and remove crontab entry
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5dbb1764bbd..b0011a4a6d3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Mon Sep 5 21:21:51 UTC 2016
pkgbase = tuptime
pkgdesc = Report the historical and statistical running time of system
- pkgver = 3.3.0
- pkgrel = 2
+ pkgver = 3.3.3
+ pkgrel = 1
url = https://github.com/rfrail3/tuptime
arch = any
license = GPL
- depends = python2
- depends = cron
- source = tuptime-3.3.0-2.tar.gz::https://github.com/rfrail3/tuptime/archive/3.3.0-2.tar.gz
- sha256sums = 0c48cea06eba819c9c0d9818c59390d16feb8dc3e8d19d2c34e9b157f1fa02ae
+ depends = python
+ optdepends = cron
+ source = tuptime-3.3.3.tar.gz::https://github.com/rfrail3/tuptime/archive/3.3.3.tar.gz
+ sha256sums = be4dc5207859eeb0e6cfef206db5dd62b553e69ac0641c7203278cdd61c95bea
pkgname = tuptime
diff --git a/PKGBUILD b/PKGBUILD
index 64bc70604508..f0b62c7e6b6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Dennis Stengele <d.stengele (at) derintendant (dot) de>
pkgname=tuptime
-pkgver=3.3.0
-pkgrel=2
+pkgver=3.3.3
+pkgrel=1
pkgdesc="Report the historical and statistical running time of system"
arch=('any')
url="https://github.com/rfrail3/tuptime"
license=('GPL')
groups=()
depends=(
- 'python2'
- 'cron'
+ 'python'
)
makedepends=()
-optdepends=()
+optdepends=('cron')
provides=()
conflicts=()
replaces=()
@@ -20,14 +19,14 @@ backup=()
options=()
install=
changelog=
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/rfrail3/tuptime/archive/${pkgver}-${pkgrel}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rfrail3/tuptime/archive/${pkgver}.tar.gz")
noextract=()
-sha256sums=('0c48cea06eba819c9c0d9818c59390d16feb8dc3e8d19d2c34e9b157f1fa02ae')
+sha256sums=('be4dc5207859eeb0e6cfef206db5dd62b553e69ac0641c7203278cdd61c95bea')
package() {
- cd "$srcdir/$pkgname-${pkgver}-${pkgrel}"
+ cd "$srcdir/$pkgname-${pkgver}"
install -Dm755 "src/tuptime" "$pkgdir/usr/bin/tuptime"
install -Dm644 "src/systemd/tuptime.service" "$pkgdir/usr/lib/systemd/system/tuptime.service"
- install -Dm644 "src/cron.d/tuptime" "$pkgdir/etc/cron.d/tuptime"
+ install -Dm644 "src/systemd/tuptime.timer" "$pkgdir/usr/lib/systemd/system/tuptime.timer"
}