summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Stengele2016-09-05 23:21:29 +0200
committerDennis Stengele2016-09-05 23:21:29 +0200
commitf5c8565aa067780d89d42b9fe39cb39991e3b43c (patch)
treea3965a9e069dcc592438773a45cc0fcea4b3abec
parentf9d5beb211c0fcda9049732a14a2f84e8f94ab5c (diff)
downloadaur-f5c8565aa067780d89d42b9fe39cb39991e3b43c.tar.gz
Bump version to 3.3.0-2 and update PKGBUILD to work with new repo organization
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94852e81eefd..64bc70604508 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Dennis Stengele <d.stengele (at) derintendant (dot) de>
pkgname=tuptime
-pkgver=3.2.01
-pkgrel=1
+pkgver=3.3.0
+pkgrel=2
pkgdesc="Report the historical and statistical running time of system"
arch=('any')
url="https://github.com/rfrail3/tuptime"
license=('GPL')
groups=()
-depends=( 'python2'
- 'cron')
+depends=(
+ 'python2'
+ 'cron'
+ )
makedepends=()
optdepends=()
provides=()
@@ -18,14 +20,14 @@ backup=()
options=()
install=
changelog=
-source=(" $pkgname-$pkgver.tar.gz::https://github.com/rfrail3/tuptime/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/rfrail3/tuptime/archive/${pkgver}-${pkgrel}.tar.gz")
noextract=()
-sha256sums=('330fbb7f9163fd1ec1c139a3e7652f86ddd2987f3e94e3b481f1a3f3e3da64c2')
+sha256sums=('0c48cea06eba819c9c0d9818c59390d16feb8dc3e8d19d2c34e9b157f1fa02ae')
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- install -Dm755 "latest/tuptime" "$pkgdir/usr/bin/tuptime"
- install -Dm644 "latest/systemd/tuptime.service" "$pkgdir/usr/lib/systemd/system/tuptime.service"
- install -Dm644 "latest/cron.d/tuptime" "$pkgdir/etc/cron.d/tuptime"
+ cd "$srcdir/$pkgname-${pkgver}-${pkgrel}"
+
+ install -Dm755 "src/tuptime" "$pkgdir/usr/bin/tuptime"
+ install -Dm644 "src/systemd/tuptime.service" "$pkgdir/usr/lib/systemd/system/tuptime.service"
+ install -Dm644 "src/cron.d/tuptime" "$pkgdir/etc/cron.d/tuptime"
}