summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-01-15 16:00:59 +0800
committertaotieren2024-01-15 16:00:59 +0800
commitca49da63403c684bfa34aa1aa09faaa0a52a7b59 (patch)
tree26d35b39fa8f8ad06b9751e2238256de23cc2105
parentb266e347bdbd7e2f4ca9188f7a6eac48f2cb2ae7 (diff)
downloadaur-ca49da63403c684bfa34aa1aa09faaa0a52a7b59.tar.gz
[lilac] updated to 0.1.0-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a94a7518e98..1b3a5149563a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = turbo-attack-git
pkgdesc = A turbo traffic generator pentesting tool to generate random traffic with random mac and ip addresses in addition to random sequence numbers to a particular ip and port.
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mytechnotalent/turbo-attack
arch = aarch64
arch = riscv64
diff --git a/PKGBUILD b/PKGBUILD
index e4613a964ce8..cf6906931372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=turbo-attack-git
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A turbo traffic generator pentesting tool to generate random traffic with random mac and ip addresses in addition to random sequence numbers to a particular ip and port."
arch=(aarch64
riscv64
@@ -29,6 +29,11 @@ pkgver() {
git describe --tags --always | sed 's/^v//;s/-/./g'
}
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
build() {
cd "${srcdir}/${pkgname}"
export CGO_CPPFLAGS="${CPPFLAGS}"