summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-01-15 14:03:18 +0800
committertaotieren2024-01-15 14:03:18 +0800
commit4056ade4af376dc4a1e8001ed5e1c82a65d661f5 (patch)
treeaf1bea9fded9c3e5994788e8862ac43d77a07d6f
downloadaur-4056ade4af376dc4a1e8001ed5e1c82a65d661f5.tar.gz
update turbo-scanner-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD60
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bf1a337da7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = turbo-scanner-git
+ pkgdesc = A port scanner and service detection tool that uses 1000 goroutines at once to scan any hosts's ip or fqdn with the sole purpose of testing your own network to ensure there are no malicious services running.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mytechnotalent/turbo-scanner
+ arch = aarch64
+ arch = riscv64
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = go
+ depends = glibc
+ depends = sudo
+ optdepends = turbo-attack: A turbo traffic generator pentesting tool to generate random traffic with random mac and ip addresses in addition to random sequence numbers to a particular ip and port.
+ provides = turbo-scanner
+ conflicts = turbo-scanner
+ options = !strip
+ source = turbo-scanner-git::git+https://github.com/mytechnotalent/turbo-scanner.git
+ sha256sums = SKIP
+
+pkgname = turbo-scanner-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f04bb79e8c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=turbo-scanner-git
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A port scanner and service detection tool that uses 1000 goroutines at once to scan any hosts's ip or fqdn with the sole purpose of testing your own network to ensure there are no malicious services running."
+arch=(aarch64
+ riscv64
+ x86_64)
+url="https://github.com/mytechnotalent/turbo-scanner"
+license=('Apache')
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+#replaces=(${pkgname})
+depends=(glibc
+ sudo)
+optdepends=("turbo-attack: A turbo traffic generator pentesting tool to generate random traffic with random mac and ip addresses in addition to random sequence numbers to a particular ip and port.")
+makedepends=(git
+ go)
+checkdepends=()
+backup=()
+options=('!strip')
+#install=${pkgname}.install
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --tags --always | sed 's/^v//;s/-/./g'
+}
+
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ mkdir -pv build/
+ go build -o build
+}
+
+# check() {
+# cd "${srcdir}/${pkgname}"
+# go test -v -cover ./...
+# go test -coverprofile=coverage.out ./...
+# go tool cover -html=coverage.out
+# }
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -Dm755 build/${pkgname%-git} -t ${pkgdir}/usr/bin/
+}