summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Reeder2016-04-24 21:45:26 -0600
committerColin Reeder2016-04-24 21:45:26 -0600
commitb551bc2e4102371061bc34c12fa955de76056376 (patch)
tree06a2adb17fbd259a08db5472c380990c6f4cb15b
downloadaur-b551bc2e4102371061bc34c12fa955de76056376.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8497307104f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = turbo-spork
+ pkgdesc = A simple RTS game
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/fictional-pancake/turbo-spork
+ arch = any
+ makedepends = apache-ant
+ depends = java-runtime
+ source = https://github.com/fictional-pancake/turbo-spork/archive/v0.2.zip
+ md5sums = 7afc54eed37e71bea7acca98c6ec9a26
+
+pkgname = turbo-spork
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2c97a85e9602
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.zip
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85cb135059eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=turbo-spork
+pkgdesc="A simple RTS game"
+pkgrel=1
+pkgver=0.2
+arch=('any')
+url="https://github.com/fictional-pancake/$pkgname"
+depends=("java-runtime")
+makedepends=("apache-ant")
+source=(
+ "$url/archive/v$pkgver.zip"
+)
+md5sums=(
+ "7afc54eed37e71bea7acca98c6ec9a26"
+)
+package () {
+ mkdir -p $pkgdir/usr/share/java/turbo-spork
+ mkdir -p $pkgdir/usr/bin
+ echo -e "#!/bin/bash\njava -jar /usr/share/java/turbo-spork/turbo-spork.jar $@" > $pkgdir/usr/bin/turbo-spork
+ chmod 755 $pkgdir/usr/bin/turbo-spork
+ cd $srcdir/$pkgname-$pkgver
+ ant jar
+ install -Dm755 build/dist/turbo-spork.jar $pkgdir/usr/share/java/turbo-spork
+}