summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weber2022-08-16 22:21:18 -0500
committerThomas Weber2022-08-16 22:21:18 -0500
commita3a093f25cbf19b009b5ab4c3cc5d012e7b05438 (patch)
treebf70f3fbf71ea640621ecfb233282660960617fe
parent06be56d43afb1888a06f1a17428e17353f67e3f5 (diff)
downloadaur-a3a093f25cbf19b009b5ab4c3cc5d012e7b05438.tar.gz
Depend on electron20 instead of electron
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--turbowarp-desktop-bin.sh2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cd8192a11a1..e49c75f71f36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = turbowarp-desktop-bin
pkgdesc = Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more.
pkgver = 1.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://desktop.turbowarp.org/
arch = any
license = GPL3
- depends = electron
+ depends = electron20
noextract = turbowarp-desktop-bin-1.5.0.tar.gz
source = turbowarp-desktop-bin-1.5.0.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v1.5.0/TurboWarp-linux-armv7l-1.5.0.tar.gz
source = turbowarp-desktop-bin.sh
source = turbowarp-desktop-bin.desktop
source = turbowarp-desktop-bin.xml
sha256sums = ec379d86a717db87c4dec1ed9f5de0c0a6779763bcd40af9e94aa42169263617
- sha256sums = 7752c9bcf60a857053b3a4262a40dd6ed2997044814dfb39e19cfa7108bcdfe4
+ sha256sums = 808433b46c27b279b9a721e3f6a8389b8914e85824b012a11d5d6d29f7663293
sha256sums = d2f66e5f85b4996d264f40142745203642b1339f77b1a99e3301092f82cfbf55
sha256sums = 931f2718e03cb9ecbdd25bf65b0e22c3d8479eb473b89cd0de26e9193738d660
diff --git a/PKGBUILD b/PKGBUILD
index a488f2ab3386..0e8a97fc0d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=turbowarp-desktop-bin
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Scratch mod with a compiler to run projects faster, dark mode for your eyes, a bunch of addons to improve the editor, and more."
arch=("any")
url="https://desktop.turbowarp.org/"
license=("GPL3")
-depends=("electron")
+depends=("electron20")
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/TurboWarp/desktop/releases/download/v$pkgver/TurboWarp-linux-armv7l-$pkgver.tar.gz"
"$pkgname.sh"
@@ -16,7 +16,7 @@ source=(
)
noextract=("$pkgname-$pkgver.tar.gz")
sha256sums=('ec379d86a717db87c4dec1ed9f5de0c0a6779763bcd40af9e94aa42169263617'
- '7752c9bcf60a857053b3a4262a40dd6ed2997044814dfb39e19cfa7108bcdfe4'
+ '808433b46c27b279b9a721e3f6a8389b8914e85824b012a11d5d6d29f7663293'
'd2f66e5f85b4996d264f40142745203642b1339f77b1a99e3301092f82cfbf55'
'931f2718e03cb9ecbdd25bf65b0e22c3d8479eb473b89cd0de26e9193738d660')
diff --git a/turbowarp-desktop-bin.sh b/turbowarp-desktop-bin.sh
index e974d35977f1..c92c3683e467 100644
--- a/turbowarp-desktop-bin.sh
+++ b/turbowarp-desktop-bin.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec electron /usr/share/turbowarp-desktop/app.asar "$@"
+exec electron20 /usr/share/turbowarp-desktop/app.asar "$@"