summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2017-12-11 23:39:23 +0100
committerLucas Werkmeister2017-12-11 23:39:23 +0100
commit000526e8eb7309df69f0553d2d82d314378c857a (patch)
treeee5a8e0f5a6409e642df3a8f7bcb1d8515a01e36
parentbb226f596b2490d4b82d66d712bfaca543fd68c9 (diff)
downloadaur-000526e8eb7309df69f0553d2d82d314378c857a.tar.gz
Update source URLs to point to GitHub
The files.turpial.org.ve URLs result in 404 Not Found.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adc33c48efd6..3217669b475f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Mon Dec 11 22:39:18 UTC 2017
pkgbase = turpial
pkgdesc = A multi-interface Twitter client written in Python.
pkgver = 3.0
@@ -21,8 +23,8 @@ pkgbase = turpial
optdepends = python2-pyqt4>=2.12: Qt user interface
optdepends = python2-jinja>=2.6: Qt user interface
conflicts = turpial-git
- source = http://files.turpial.org.ve/sources/stable/turpial-3.0.tar.gz
- sha1sums = f47af9b7e4ffbf5b2dcd7ed4d81fd55a212b072c
+ source = https://github.com/satanas/Turpial/archive/3.0.tar.gz
+ sha256sums = af13a168f1f109a06f4edfd6426c50eaf8d10105031b8d27355e97b0dab500d9
pkgname = turpial
diff --git a/PKGBUILD b/PKGBUILD
index 9670aed2df58..fcb882cb4586 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Contributor: Miguel Useche <migueluseche(dot)skatox.com>
pkgname=turpial
+pkgname_=Turpial
pkgver=3.0
pkgrel=1
pkgdesc="A multi-interface Twitter client written in Python."
@@ -19,15 +20,15 @@ optdepends=(
)
# TODO is it really correct that pywebkitgtk is required but the GTK UI is optional?
conflicts=(${pkgname}-git)
-source=(http://files.turpial.org.ve/sources/stable/$pkgname-$pkgver.tar.gz)
-sha1sums=('f47af9b7e4ffbf5b2dcd7ed4d81fd55a212b072c') # ${source[0]}.sha1sum
+source=(https://github.com/satanas/$pkgname_/archive/$pkgver.tar.gz)
+sha256sums=('af13a168f1f109a06f4edfd6426c50eaf8d10105031b8d27355e97b0dab500d9')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname_-$pkgver"
python2 setup.py build || return 1
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname_-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1 || return 1
}