summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2015-11-26 21:45:05 +0100
committerLucas Werkmeister2015-11-26 21:45:05 +0100
commitbb226f596b2490d4b82d66d712bfaca543fd68c9 (patch)
treeb365771102c18b6ca555e4decb241cc09be2b342
parent74145d637114d4862b55d56899800cabbb6568fe (diff)
downloadaur-bb226f596b2490d4b82d66d712bfaca543fd68c9.tar.gz
Fix dependencies
Add missing qt dependencies (thanks to AUR user kaczus for the info!), and make both gtk and qt dependencies optional.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41d959875646..adc33c48efd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,15 +9,17 @@ pkgbase = turpial
depends = libturpial>=0.8
depends = python2-distribute
depends = python2-simplejson>=1.9.2
- depends = pygtk>=2.12
depends = python2-notify2>=0.1.1
depends = notification-daemon
depends = gstreamer0.10-python
depends = python2-babel>=0.9.1
depends = pywebkitgtk
- optdepends = python2-gtkspell>=2.25.3
- optdepends = gnome-spell
- optdepends = aspell
+ optdepends = pygtk>=2.12: GTK user interface
+ optdepends = aspell: GTK user interface
+ optdepends = gnome-spell: GTK user interface
+ optdepends = python2-gtkspell>=2.25.3: GTK user interface
+ optdepends = python2-pyqt4>=2.12: Qt user interface
+ optdepends = python2-jinja>=2.6: Qt user interface
conflicts = turpial-git
source = http://files.turpial.org.ve/sources/stable/turpial-3.0.tar.gz
sha1sums = f47af9b7e4ffbf5b2dcd7ed4d81fd55a212b072c
diff --git a/PKGBUILD b/PKGBUILD
index ab896f149ef1..9670aed2df58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,16 @@ pkgdesc="A multi-interface Twitter client written in Python."
arch=(any)
url="http://turpial.org.ve/"
license=('GPL3')
-depends=('python2' 'libturpial>=0.8' 'python2-distribute' 'python2-simplejson>=1.9.2' 'pygtk>=2.12' 'python2-notify2>=0.1.1' 'notification-daemon' 'gstreamer0.10-python' 'python2-babel>=0.9.1' 'pywebkitgtk')
-optdepends=('python2-gtkspell>=2.25.3' 'gnome-spell' 'aspell')
+depends=('python2' 'libturpial>=0.8' 'python2-distribute' 'python2-simplejson>=1.9.2' 'python2-notify2>=0.1.1' 'notification-daemon' 'gstreamer0.10-python' 'python2-babel>=0.9.1' 'pywebkitgtk')
+optdepends=(
+ 'pygtk>=2.12: GTK user interface'
+ 'aspell: GTK user interface'
+ 'gnome-spell: GTK user interface'
+ 'python2-gtkspell>=2.25.3: GTK user interface'
+ 'python2-pyqt4>=2.12: Qt user interface'
+ 'python2-jinja>=2.6: Qt user interface'
+)
+# TODO is it really correct that pywebkitgtk is required but the GTK UI is optional?
conflicts=(${pkgname}-git)
source=(http://files.turpial.org.ve/sources/stable/$pkgname-$pkgver.tar.gz)
sha1sums=('f47af9b7e4ffbf5b2dcd7ed4d81fd55a212b072c') # ${source[0]}.sha1sum