summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2015-08-09 16:00:44 +0200
committerLucas Werkmeister2015-08-09 17:05:52 +0200
commitf4d5aa0b1267bfb85cb2934fe36bf6e183c29f74 (patch)
tree6936f908072bcdedc7e34d6f47fcf5e94fd24d22
downloadaur-f4d5aa0b1267bfb85cb2934fe36bf6e183c29f74.tar.gz
Initial import
Source: http://pkgbuild.com/git/aur-mirror.git/plain/turpial/PKGBUILD
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD19
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a1edb3c2d0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = turpial
+ pkgdesc = A multi-interface Twitter client written in Python.
+ pkgver = 1.6.8
+ pkgrel = 1
+ url = http://turpial.org.ve/
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python2-distribute
+ depends = python-simplejson>=1.9.2
+ depends = pygtk>=2.12
+ depends = python-notify>=0.1.1
+ depends = notification-daemon
+ depends = gstreamer0.10-python
+ depends = python-babel>=0.9.1
+ depends = pywebkitgtk
+ optdepends = python2-gtkspell>=2.25.3
+ optdepends = gnome-spell
+ optdepends = aspell
+ conflicts = turpial
+ source = http://turpial.org.ve/files/sources/stable/turpial-1.6.8.tar.gz
+ md5sums = 04bdd05c3aca2f6ee4ff1f6d95e64b30
+
+pkgname = turpial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..deec8aa8642a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Miguel Useche <migueluseche(dot)skatox.com>
+pkgname=turpial
+pkgver=1.6.8
+pkgrel=1
+pkgdesc="A multi-interface Twitter client written in Python."
+arch=(any)
+url="http://turpial.org.ve/"
+license=('GPL3')
+depends=('python2' 'python2-distribute' 'python-simplejson>=1.9.2' 'pygtk>=2.12' 'python-notify>=0.1.1' 'notification-daemon' 'gstreamer0.10-python' 'python-babel>=0.9.1'
+'pywebkitgtk')
+optdepends=('python2-gtkspell>=2.25.3' 'gnome-spell' 'aspell')
+conflicts=('turpial')
+source=(http://turpial.org.ve/files/sources/stable/$pkgname-$pkgver.tar.gz)
+md5sums=('04bdd05c3aca2f6ee4ff1f6d95e64b30')
+
+build() {
+ cd $srcdir/$pkgname-${pkgver//_/-}
+ python2 setup.py install --root=$pkgdir/ --optimize=1 || return 1
+} \ No newline at end of file