summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneoninteger2019-11-14 16:16:40 +1030
committerneoninteger2019-11-14 16:36:13 +1030
commit1da424bb0ed0ef0e4a574b809dd1c7fb53bf6420 (patch)
tree9ca2d0cb095158ed046db1d0e5e075c3f9d97bdf
parentac465e3053bdfc56c2d06987663e8fcad5f87aaf (diff)
downloadaur-1da424bb0ed0ef0e4a574b809dd1c7fb53bf6420.tar.gz
Add patch to update rusqlite version
This version of core-rs depends on rusqlite version 0.13.0, which cannot be built on current versions of rust. I have added a patch to update all instances of rusqlite to version 0.14.0, the first release to contain the fix for newer compiler versions.
-rw-r--r--PKGBUILD14
-rw-r--r--rusqlite.patch34
2 files changed, 46 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc0913e6147e..867ef89a69be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,10 +17,20 @@ _commithash="774fa361d021d9ef5237d32d09515ab7b2a32ad2"
source=("https://github.com/turtl/core-rs/archive/${_commithash}.tar.gz"
"config-client.yaml"
- "config-server.yaml")
+ "config-server.yaml"
+ "rusqlite.patch")
sha256sums=("71c1caf3aeb6245040abb0ee063b574dd6ece6314c60edabbe4299a11df49b68"
"f5400e9c80c935915212e818f05eab8d3d542a54ed89e153c20a6c0fa00d8e1a"
- "1b46d55e5f4753a494ceb005783db1c0c0908195b4f18a38a99118ecffae110a")
+ "1b46d55e5f4753a494ceb005783db1c0c0908195b4f18a38a99118ecffae110a"
+ "cd784b2b1de7bb0dba4d92623a525fc970627fd60b44b41d6f2d8e520770fce4")
+
+prepare() {
+ # This version of Turtl depends on an old version of rusqlite (v0.13.0)
+ # which can't be built on current versions of Rust. This patch updates the
+ # version of rusqlite used to v0.14.0, the first release to contain the
+ # fix that allows it to compile again.
+ patch -Np0 -i rusqlite.patch
+}
build() {
export OPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0
diff --git a/rusqlite.patch b/rusqlite.patch
new file mode 100644
index 000000000000..da04d114fae8
--- /dev/null
+++ b/rusqlite.patch
@@ -0,0 +1,34 @@
+diff -rupN core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2.orig/Cargo.toml core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2/Cargo.toml
+--- core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2.orig/Cargo.toml 2019-11-14 15:41:30.353803437 +1030
++++ core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2/Cargo.toml 2019-11-14 12:42:07.004160374 +1030
+@@ -45,7 +45,7 @@ num_cpus = "1.8.0"
+ protected_derive = { path = "protected_derive" }
+ quick-error = "1.2.2"
+ regex = "0.1.77"
+-rusqlite = "0.13.0"
++rusqlite = "0.14.0"
+ serde = "1.0.8"
+ serde_derive = "1.0.8"
+ serde_json = "1.0.2"
+diff -rupN core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2.orig/clouseau/Cargo.toml core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2/clouseau/Cargo.toml
+--- core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2.orig/clouseau/Cargo.toml 2019-11-14 15:41:30.357136770 +1030
++++ core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2/clouseau/Cargo.toml 2019-11-14 12:42:30.750826254 +1030
+@@ -5,5 +5,5 @@ authors = ["Andrew Danger Lyon <orthecre
+
+ [dependencies]
+ quick-error = "1.2.2"
+-rusqlite = "0.13.0"
++rusqlite = "0.14.0"
+
+diff -rupN core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2.orig/dumpy/Cargo.toml core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2/dumpy/Cargo.toml
+--- core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2.orig/dumpy/Cargo.toml 2019-11-14 15:41:30.357136770 +1030
++++ core-rs-774fa361d021d9ef5237d32d09515ab7b2a32ad2/dumpy/Cargo.toml 2019-11-14 12:42:57.057492048 +1030
+@@ -6,7 +6,7 @@ authors = ["Andrew Danger Lyon <orthecre
+ [dependencies]
+ jedi = { path = "../jedi" }
+ libc = "0.2.15"
+-rusqlite = "0.13.0"
++rusqlite = "0.14.0"
+ quick-error = "1.2.2"
+ serde = "1.0.8"
+ serde_json = "1.0.2"