summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneoninteger2019-11-14 18:28:54 +1030
committerneoninteger2019-11-14 18:28:54 +1030
commit7951354b5bedba7de72a1b723b5fb7a8dcdfe18c (patch)
tree074a2de24f6597d5d8dc61b211f9cea52ed54e75
parentd05747b3ec3599b0771554de20449c29521a8e11 (diff)
downloadaur-7951354b5bedba7de72a1b723b5fb7a8dcdfe18c.tar.gz
Move server plugins directory to local prefix
Rather than using the system plugins directory for the Turtl server (which may have plugins that can interfere with the integration tests) we make a blank plugins directory within the source tree that prevents such plugins from being loaded.
-rw-r--r--PKGBUILD3
-rw-r--r--config-server.yaml2
2 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 302a9812eb9c..d6c26488d92f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ source=("https://github.com/turtl/core-rs/archive/${_commithash}.tar.gz"
"rusqlite.patch")
sha256sums=("71c1caf3aeb6245040abb0ee063b574dd6ece6314c60edabbe4299a11df49b68"
"31791752feae4d5b0a19272bbb15df827bf67bb9df237e45431dc4b15b212c2e"
- "07cdaff828f3743b78693b029c8023d703874c4a612c64b3f9cf0608065b397b"
+ "f3c974201d4d7b8bc00e51595cb0738d3772fd3bbd73624abc32536838465308"
"cd784b2b1de7bb0dba4d92623a525fc970627fd60b44b41d6f2d8e520770fce4")
prepare() {
@@ -91,6 +91,7 @@ check() {
cp -r /usr/share/webapps/turtl/helpers helpers
cp -r /usr/share/webapps/turtl/models models
cp -r /usr/share/webapps/turtl/node_modules node_modules
+ mkdir plugins
cp -r /usr/share/webapps/turtl/scripts scripts
cp -r /usr/share/webapps/turtl/tools tools
cp /usr/share/webapps/turtl/server.js server.js
diff --git a/config-server.yaml b/config-server.yaml
index 846182577642..1c5f9e14d09a 100644
--- a/config-server.yaml
+++ b/config-server.yaml
@@ -37,7 +37,7 @@ sync:
max_bulk_sync_records: 32
plugins:
- plugin_location: '/usr/share/webapps/turtl/plugins'
+ plugin_location: 'plugins'
# each key here corresponds to a folder name in the plugins folder, so `email`
# below would be a plugin at usr/share/webapps/turtl/plugins/email (see the
# example-plugins/ folder for an email plugin you can use)