summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOwen Trigueros2019-05-15 00:01:49 +0200
committerOwen Trigueros2019-05-15 00:01:49 +0200
commitc6c6bcee01f7048f0972b18e80f366a7992c14c9 (patch)
tree5d1bad8fc46d1c3df48b9df838669ea7a0d20059
parent832e37c661ec641e0cf7e3c6348fc6bb9014952c (diff)
downloadaur-c6c6bcee01f7048f0972b18e80f366a7992c14c9.tar.gz
remove _$pkgname, fix license, fix source protocols
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD37
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 990d0f1339de..488a01868a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,12 @@ pkgbase = turtl-server-git
url = https://turtlapp.com/
install = turtl-server-git.install
arch = any
- license = GPL3
+ license = AGPL
makedepends = git
makedepends = npm
depends = nodejs
depends = postgresql
- source = turtl-server-git::git+git://github.com/turtl/server.git
+ source = turtl-server-git::git+https://github.com/turtl/server.git
source = turtl.conf
source = turtl-server-git.install
source = turtl.service
diff --git a/PKGBUILD b/PKGBUILD
index c8e28120f1d6..d82f5b5f2629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
pkgname=turtl-server-git
-_pkgname=server
pkgver=r209.f37f183
pkgrel=1
pkgdesc="The secure, collaborative notebook's server"
arch=('any')
url="https://turtlapp.com/"
-license=('GPL3')
+license=('AGPL')
depends=('nodejs' 'postgresql')
makedepends=('git' 'npm')
install=$pkgname.install
-source=("$pkgname::git+git://github.com/turtl/server.git"
+source=("$pkgname::git+https://github.com/turtl/server.git"
"turtl.conf"
"turtl-server-git.install"
"turtl.service")
@@ -34,26 +33,18 @@ build() {
package() {
mkdir -p "$pkgdir"/var/www/turtl/server
mkdir -p "$pkgdir"/var/www/turtl/server/plugins
+
+ install -Dm644 turtl.service "$pkgdir"/usr/lib/systemd/system/turtl.service
+ install -Dm644 turtl.conf "$pkgdir"/usr/lib/sysusers.d/turtl.conf
- cp -r "$srcdir"/"$pkgname"/controllers \
- "$pkgdir"/var/www/turtl/server
- cp -r "$srcdir"/"$pkgname"/helpers \
- "$pkgdir"/var/www/turtl/server
- cp -r "$srcdir"/"$pkgname"/models \
- "$pkgdir"/var/www/turtl/server
- cp -r "$srcdir"/"$pkgname"/node_modules \
- "$pkgdir"/var/www/turtl/server
- cp -r "$srcdir"/"$pkgname"/scripts \
- "$pkgdir"/var/www/turtl/server
- cp -r "$srcdir"/"$pkgname"/tools \
- "$pkgdir"/var/www/turtl/server
+ cd "$srcdir"/"$pkgname"
+ cp -r controllers $pkgdir/var/www/turtl/server
+ cp -r helpers "$pkgdir"/var/www/turtl/server
+ cp -r models "$pkgdir"/var/www/turtl/server
+ cp -r node_modules "$pkgdir"/var/www/turtl/server
+ cp -r scripts "$pkgdir"/var/www/turtl/server
+ cp -r tools "$pkgdir"/var/www/turtl/server
- install -Dm644 "$srcdir"/"$pkgname"/config/config.yaml.default \
- "$pkgdir"/var/www/turtl/server/config/config.yaml
- install -Dm644 "$srcdir"/"$pkgname"/server.js \
- "$pkgdir"/var/www/turtl/server/server.js
- install -Dm644 turtl.service \
- "$pkgdir"/usr/lib/systemd/system/turtl.service
- install -Dm644 turtl.conf \
- "$pkgdir"/usr/lib/sysusers.d/turtl.conf
+ install -Dm644 config/config.yaml.default "$pkgdir"/var/www/turtl/server/config/config.yaml
+ install -Dm644 server.js "$pkgdir"/var/www/turtl/server/server.js
}