summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzpalmtree2018-10-29 06:32:41 +0000
committerzpalmtree2018-10-29 06:32:41 +0000
commita39f9525a2f72cc8852541ab6eba23e3360e8fec (patch)
tree3948fef0e449a1d3eabdfcdc3fe556be0c6aed5a
parent5504e1737479c675b57efbc0e084b7498899e199 (diff)
downloadaur-a39f9525a2f72cc8852541ab6eba23e3360e8fec.tar.gz
Update to v0.8.4
-rw-r--r--PKGBUILD33
-rw-r--r--turtlecoin-bin.install36
2 files changed, 16 insertions, 53 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6794c1909468..d2304ec34ee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,25 @@
-#
-# Please note:
-# Export your keys using export_keys command in
-# trtl-simplewallet before upgrading to version
-# 0.4.3.
-#
-# For more information visit:
-# https://github.com/turtlecoin/turtlecoin/releases/tag/v0.4.3
-#
-
pkgname=turtlecoin-bin
-pkgver=v0.4.3
+pkgver=v0.8.4
pkgrel=1
-pkgdesc="Turtlecoin simplewallet and miner"
+pkgdesc="Turtlecoin daemon, CLI wallet, RPC interface, and solo miner"
arch=('x86_64')
url="https://turtlecoin.lol"
license=('LGPLv3')
install="${pkgname}.install"
conflicts=('turtlecoin-git')
-source=("https://github.com/turtlecoin/turtlecoin/releases/download/${pkgver}/turtlecoin-${pkgver}-linux-static.tar.gz")
-sha256sums=('4cde75bb25804ecdab4049cd1eeb65107018c7833c70f1cb146feaeae5124ca3')
+source=("https://github.com/turtlecoin/turtlecoin/releases/download/${pkgver}/turtlecoin-${pkgver}-linux.tar.gz")
+sha256sums=('dffb14bdf5140ca27cb905f527110ae262009d2e32e9e8c60f43b636b4e41a9e')
package() {
# extract the tarball
- tar xfz turtlecoin-${pkgver}-linux-static.tar.gz
+ tar xfz turtlecoin-${pkgver}-linux.tar.gz
+
+ # Not the same as pkgver :(
+ version_string=v.0.8.4
- install -D -m755 "turtlecoin-${pkgver}-linux-static/miner" -T "$pkgdir/usr/bin/trtl-miner"
- install -D -m755 "turtlecoin-${pkgver}-linux-static/simplewallet" -T "$pkgdir/usr/bin/trtl-simplewallet"
- install -D -m755 "turtlecoin-${pkgver}-linux-static/TurtleCoind" -t "$pkgdir/usr/bin/"
- install -D -m755 "turtlecoin-${pkgver}-linux-static/walletd" -T "$pkgdir/usr/bin/trtl-walletd"
- install -D -m755 "turtlecoin-${pkgver}-linux-static/poolwallet" -T "$pkgdir/usr/bin/trtl-poolwallet"
+ # Rename some executables so we don't conflict with other coins
+ install -D -m755 "turtlecoin-${version_string}/miner" -T "$pkgdir/usr/bin/trtl-miner"
+ install -D -m755 "turtlecoin-${version_string}/zedwallet" -T "$pkgdir/usr/bin/trtl-zedwallet"
+ install -D -m755 "turtlecoin-${version_string}/TurtleCoind" -t "$pkgdir/usr/bin/"
+ install -D -m755 "turtlecoin-${version_string}/turtle-service" -t "$pkgdir/usr/bin/"
}
diff --git a/turtlecoin-bin.install b/turtlecoin-bin.install
index e1d519d6d533..2c684cb0c8ec 100644
--- a/turtlecoin-bin.install
+++ b/turtlecoin-bin.install
@@ -1,42 +1,12 @@
binary_message() {
echo "To prevent problems with software of other coins the binaries for this package are as follows:"
- echo " connectivity_tool => trtl-connectivity_tool"
echo " miner => trtl-miner"
- echo " simplewallet => trtl-simplewallet"
- echo " walletd => trtl-walletd"
+ echo " zedwallet => trtl-zedwallet"
+ echo " TurtleCoind => unchanged"
+ echo " turtle-service => unchanged"
echo
}
-to_v0.3.2_upgrade_message() {
-cat << EOF
-
-How To Upgrade from an older version to v0.3.2 (r135.7fcc6ad):
- * run the old TurtleCoind to sync your chain fully
- * with the old TurtleCoind fully synced, open simplewallet
- * open your wallet
- * export your SPEND and VIEW keys with export_keys, this is important.
- * Close the old version folder TurtleCoind and simplewallet by typing exit into each window
- * Run the new TurtleCoind
- * Run the new simplewallet
- * Press I for IMPORT in simplewallet
- * Use any filename for the wallet name, it does not have to be the same
- * Use any password for wallet password, it does not have to be the same as the last
- * Enter your spend_key and your view_key from step 4
-
-For more information visit:
- https://github.com/turtlecoin/turtlecoin/releases/tag/v0.3.2
-
-EOF
-}
-
-pre_install() {
- to_v0.3.2_upgrade_message
-}
-
-pre_upgrade() {
- to_v0.3.2_upgrade_message
-}
-
post_install() {
binary_message
}