summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWalter Reiner2018-02-11 20:03:33 +0000
committerWalter Reiner2018-02-11 20:03:33 +0000
commitfa100a86d4f7d9cfcfef0cee8cc8a15f5fa93978 (patch)
treebb3fc25df76329e2ff145b4c90e4cd15a95191f3
parent0adbca0cbde47a06400635cc3374a68de715cdc1 (diff)
downloadaur-fa100a86d4f7d9cfcfef0cee8cc8a15f5fa93978.tar.gz
New version, changed License
Changed PKGBUILD to use new v0.3.2 Changed license to LGPLv3 Added install/upgrade notice to .install file for v0.3.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--turtlecoin-git.install30
3 files changed, 44 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ecbfc2c89e8..666e8914d81c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = turtlecoin-git
pkgdesc = Turtlecoin simplewallet and miner
- pkgver = r126.f6cf18d
+ pkgver = r135.7fcc6ad
pkgrel = 1
url = https://turtlecoin.lol
install = turtlecoin-git.install
arch = x86_64
- license = custom
+ license = LGPLv3
makedepends = git
makedepends = cmake
depends = boost-libs
diff --git a/PKGBUILD b/PKGBUILD
index d80fb24c1d5c..79d111f2ee3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,20 @@
+#
+# Please note:
+# Export your keys using export_keys command in
+# trtl-simplewallet before upgrading to version
+# 0.3.2 (r135.7fcc6ad).
+#
+# For more information visit:
+# https://github.com/turtlecoin/turtlecoin/releases/tag/v0.3.2
+#
+
pkgname=turtlecoin-git
-pkgver=r126.f6cf18d
+pkgver=r135.7fcc6ad
pkgrel=1
pkgdesc="Turtlecoin simplewallet and miner"
arch=('x86_64')
url="https://turtlecoin.lol"
-license=('custom')
+license=('LGPLv3')
install="${pkgname}.install"
makedepends=('git' 'cmake')
depends=('boost-libs' 'boost')
diff --git a/turtlecoin-git.install b/turtlecoin-git.install
index fb6d8a35c429..e1d519d6d533 100644
--- a/turtlecoin-git.install
+++ b/turtlecoin-git.install
@@ -7,6 +7,36 @@ binary_message() {
echo
}
+to_v0.3.2_upgrade_message() {
+cat << EOF
+
+How To Upgrade from an older version to v0.3.2 (r135.7fcc6ad):
+ * run the old TurtleCoind to sync your chain fully
+ * with the old TurtleCoind fully synced, open simplewallet
+ * open your wallet
+ * export your SPEND and VIEW keys with export_keys, this is important.
+ * Close the old version folder TurtleCoind and simplewallet by typing exit into each window
+ * Run the new TurtleCoind
+ * Run the new simplewallet
+ * Press I for IMPORT in simplewallet
+ * Use any filename for the wallet name, it does not have to be the same
+ * Use any password for wallet password, it does not have to be the same as the last
+ * Enter your spend_key and your view_key from step 4
+
+For more information visit:
+ https://github.com/turtlecoin/turtlecoin/releases/tag/v0.3.2
+
+EOF
+}
+
+pre_install() {
+ to_v0.3.2_upgrade_message
+}
+
+pre_upgrade() {
+ to_v0.3.2_upgrade_message
+}
+
post_install() {
binary_message
}