summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2017-06-03 11:36:08 -0400
committerJean Lucas2017-06-03 11:55:10 -0400
commite1a364f55fc0029d8a61eff8917b8b3b7ed37bab (patch)
tree7d34e1176bb18c8e52cdc02daddcf46a77a4b6bd
parent5cbdf21f7ac9f6fc3b3df12de3b01619995bbfaf (diff)
downloadaur-e1a364f55fc0029d8a61eff8917b8b3b7ed37bab.tar.gz
added patch to update karma dependency in package.json; thanks xieyuheng! version bump to 2.14.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--update-karma.patch11
3 files changed, 34 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61e059692da9..4ef59bb53494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Sat Oct 29 20:04:23 UTC 2016
+# Sat Jun 3 15:49:24 UTC 2017
pkgbase = tutanota
- pkgdesc = Tutanota is the end-to-end encrypted mail client that enables you to communicate securely with anyone.
- pkgver = 2.12.0
+ pkgdesc = Web-based client for Tutanota's end-to-end encrypted mail service
+ pkgver = 2.14.4
pkgrel = 1
- url = https://tutanota.de
+ url = https://tutanota.com
arch = any
license = GPL3
makedepends = npm
makedepends = gulp
- source = https://github.com/tutao/tutanota/archive/tutanota-release-2.12.0.tar.gz
- sha1sums = 7a06a748f06f233f0e4e506899c66c76feb887aa
+ source = https://github.com/tutao/tutanota/archive/tutanota-release-2.14.4.tar.gz
+ source = update-karma.patch
+ sha256sums = f0ff0feae83494ce2eb84abdce35c22d16a5d589e42d5044238ca72f1eeb5cfc
+ sha256sums = 5772735c89d935d0511b00b22e50d5424a81ffc682fb473f13810c77e60dea75
pkgname = tutanota
diff --git a/PKGBUILD b/PKGBUILD
index 2334be089aa1..89edd367b39f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
-# Maintainer: Jean Lucas <jean at 4ray dot co>
+# Maintainer: Jean Lucas <jean@4ray.co>
# Contributor: dacoit <dacoit at tuta dot io>
pkgname=tutanota
-pkgver=2.12.0
+pkgver=2.14.4
pkgrel=1
-pkgdesc='Tutanota is the end-to-end encrypted mail client that enables you to communicate securely with anyone.'
-url='https://tutanota.de'
+pkgdesc="Web-based client for Tutanota's end-to-end encrypted mail service"
+url="https://tutanota.com"
arch=('any')
license=('GPL3')
-makedepends=(npm gulp)
-source=("https://github.com/tutao/tutanota/archive/tutanota-release-$pkgver.tar.gz")
-sha1sums=('7a06a748f06f233f0e4e506899c66c76feb887aa')
+makedepends=('npm' 'gulp')
+source=("https://github.com/tutao/tutanota/archive/tutanota-release-$pkgver.tar.gz"
+ "update-karma.patch")
+sha256sums=('f0ff0feae83494ce2eb84abdce35c22d16a5d589e42d5044238ca72f1eeb5cfc'
+ '5772735c89d935d0511b00b22e50d5424a81ffc682fb473f13810c77e60dea75')
-# Set to any value to install a symlink
-# from the document root to the webapp
+# Set to any value to install a symlink from the document root to the webapp
_doc_root_symlink=
_doc_root="/srv/http"
+prepare() {
+ cd "$srcdir"
+ patch -Np0 < update-karma.patch
+}
+
build() {
cd "$pkgname-$pkgname-release-$pkgver/web"
npm install
diff --git a/update-karma.patch b/update-karma.patch
new file mode 100644
index 000000000000..95379768a618
--- /dev/null
+++ b/update-karma.patch
@@ -0,0 +1,11 @@
+--- tutanota-tutanota-release-2.14.4/package.json 2017-01-25 07:15:05.000000000 -0500
++++ tutanota-tutanota-release-2.14.4/package.json 2017-06-03 11:13:18.982147751 -0400
+@@ -30,7 +30,7 @@
+ "gulp-sort": "1.0.1",
+ "gulp-sourcemaps": "~1.1.0",
+ "gulp-uglify": "~0.3.1",
+- "karma": "~0.12.16",
++ "karma": "^1.0",
+ "karma-chai": "~0.1.0",
+ "karma-chai-plugins": "^0.2.3",
+ "karma-chrome-launcher": "~0.1.4",