summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-20 10:26:52 -0700
committerMark Wagie2022-01-20 10:26:52 -0700
commit2dfc423beb69663d91cb003c446f0983c2e880eb (patch)
tree4a79c3d0485537c80bc179445f898d901cb1d52a
parent4f063bd4fe2598bb1f6a80f6f6eb055ee9a0df27 (diff)
downloadaur-2dfc423beb69663d91cb003c446f0983c2e880eb.tar.gz
3.91.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1963c903b8d..68aff55d85f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tutanota-desktop
pkgdesc = Official Tutanota email client
- pkgver = 3.89.25
+ pkgver = 3.91.2
pkgrel = 1
url = https://tutanota.com
arch = x86_64
@@ -11,10 +11,10 @@ pkgbase = tutanota-desktop
depends = libappindicator-gtk3
depends = libnotify
depends = org.freedesktop.secrets
- source = https://github.com/tutao/tutanota/archive/tutanota-release-3.89.25.tar.gz
+ source = https://github.com/tutao/tutanota/archive/tutanota-release-3.91.2.tar.gz
source = tutanota-desktop
source = tutanota-desktop.desktop
- sha256sums = b59eef920ea9a9f4a930b38333d5f059ea891f5a7baf3e92b0ad91b8a9d269f3
+ sha256sums = 8e19dc808df954e5475143b9bc9842082b9e9fcbd6189a4f643d7db9ec53321b
sha256sums = 4f91e842bd92a3312943854383e4929f9baf6cb684a7027aa55edcce1bf4ca16
sha256sums = 9a41e5474e1568b13093c91fd54538fe614003f5f5d4f895553f73207c28cb08
diff --git a/PKGBUILD b/PKGBUILD
index 3e79ee6ad518..33418a02c1a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Aaron J. Graves <linux@ajgraves.com>
# Contributor: ganthern <https://github.com/ganthern>
pkgname=tutanota-desktop
-pkgver=3.89.25
+pkgver=3.91.2
pkgrel=1
pkgdesc="Official Tutanota email client"
arch=('x86_64')
@@ -13,14 +13,15 @@ makedepends=('nodejs>=16' 'npm>=7')
source=("https://github.com/tutao/tutanota/archive/${pkgname%-*}-release-$pkgver.tar.gz"
"$pkgname"
"$pkgname.desktop")
-sha256sums=('b59eef920ea9a9f4a930b38333d5f059ea891f5a7baf3e92b0ad91b8a9d269f3'
+sha256sums=('8e19dc808df954e5475143b9bc9842082b9e9fcbd6189a4f643d7db9ec53321b'
'4f91e842bd92a3312943854383e4929f9baf6cb684a7027aa55edcce1bf4ca16'
'9a41e5474e1568b13093c91fd54538fe614003f5f5d4f895553f73207c28cb08')
build() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
export npm_config_cache="$srcdir/npm_cache"
- npm install
+ npm ci
+ npm run build-packages
node dist -l --custom-desktop-release --unpacked
}