summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-07-26 08:26:21 -0600
committerMark Wagie2022-07-26 08:26:21 -0600
commit72c0edd422e86e91edc50288257514442b212e04 (patch)
tree174f54e7ee5b626b2c9643cafb5b99c75d10edd6
parentf8e5e6f1b45d2d84eb28180e4e61fccf5c310d44 (diff)
downloadaur-72c0edd422e86e91edc50288257514442b212e04.tar.gz
3.98.15
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1dc0f5151e5..4ab373d55b03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tutanota-desktop
pkgdesc = Official Tutanota email client
- pkgver = 3.98.12
+ pkgver = 3.98.15
pkgrel = 1
url = https://tutanota.com
arch = x86_64
@@ -12,9 +12,9 @@ pkgbase = tutanota-desktop
depends = libsecret
depends = nss
optdepends = libappindicator-gtk3: StatusNotifierItem support
- source = https://github.com/tutao/tutanota/archive/tutanota-release-3.98.12.tar.gz
+ source = https://github.com/tutao/tutanota/archive/tutanota-desktop-release-3.98.15.tar.gz
source = tutanota-desktop.desktop
- sha256sums = a8d20d5e786514f953d36fabcc50ee965977c69ddb53500b310e5ac00b8f32ec
+ sha256sums = b1f16e779f08ae76b2910615cee6688bda080286fb39306cc2c796a58c459e68
sha256sums = 9a41e5474e1568b13093c91fd54538fe614003f5f5d4f895553f73207c28cb08
pkgname = tutanota-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 0f0ffb50f126..b229bd5c56c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Aaron J. Graves <linux@ajgraves.com>
# Contributor: ganthern <https://github.com/ganthern>
pkgname=tutanota-desktop
-pkgver=3.98.12
+pkgver=3.98.15
pkgrel=1
pkgdesc="Official Tutanota email client"
arch=('x86_64')
@@ -12,9 +12,9 @@ depends=('alsa-lib' 'gtk3' 'libsecret' 'nss')
#makedepends=('node-gyp>=9.0.0' 'nodejs>=16.3.0' 'npm>=7.0.0')
makedepends=('nvm' 'python')
optdepends=('libappindicator-gtk3: StatusNotifierItem support')
-source=("https://github.com/tutao/tutanota/archive/${pkgname%-*}-release-$pkgver.tar.gz"
+source=("https://github.com/tutao/tutanota/archive/$pkgname-release-$pkgver.tar.gz"
"$pkgname.desktop")
-sha256sums=('a8d20d5e786514f953d36fabcc50ee965977c69ddb53500b310e5ac00b8f32ec'
+sha256sums=('b1f16e779f08ae76b2910615cee6688bda080286fb39306cc2c796a58c459e68'
'9a41e5474e1568b13093c91fd54538fe614003f5f5d4f895553f73207c28cb08')
_ensure_local_nvm() {
@@ -28,13 +28,13 @@ _ensure_local_nvm() {
}
prepare() {
- cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
+ cd "${pkgname%-*}-$pkgname-release-$pkgver"
_ensure_local_nvm
nvm install
}
build() {
- cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
+ cd "${pkgname%-*}-$pkgname-release-$pkgver"
export npm_config_cache="$srcdir/npm_cache"
_ensure_local_nvm
npm ci
@@ -43,7 +43,7 @@ build() {
}
package() {
- cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
+ cd "${pkgname%-*}-$pkgname-release-$pkgver"
install -d "$pkgdir/opt/$pkgname/"
cp -av build/desktop/linux-unpacked/* \
"$pkgdir/opt/$pkgname/"