summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLarry Dewey2016-12-29 17:27:44 -0700
committerLarry Dewey2016-12-29 17:27:44 -0700
commit698171327c0f25d5522bc6281ee80591273d20cf (patch)
tree652bacaa67d9226f3162873f6a56f8cde33f731b
downloadaur-698171327c0f25d5522bc6281ee80591273d20cf.tar.gz
Initial Commit of tutanota-electron-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
-rw-r--r--tutanota-electron-git.install7
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a42e21de08f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tutanota-electron-git
+ pkgdesc = A secure email client
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://bitbucket.org/Thesilentdrifter/tutanota-electron
+ arch = x86_64
+ depends = gulp-cli
+ depends = npm
+ source = https://bitbucket.org/Thesilentdrifter/tutanota-electron/raw/9a7e8dd0c44f5f43e931a79556512bffe9415431/tutanota-electron-git.tar.gz
+ md5sums = 51466202ad0c301f5d3605b7226cfa4b
+ sha512sums = 639b841f8a668514bcdac1c4f16a6ae35d5e81a25d1fc09291a0a5b2eb7a6fa9d19346ab8baaeffb5bfbad3c7485d243f9a5b534fe20332375fd3c3b2474b42b
+
+pkgname = tutanota-electron-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1735bd32f44b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: TheSilentDrifter a.k.a Larry Dewey <larry.j.dewey@gmail.com>
+
+pkgname=tutanota-electron-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A secure email client"
+arch=('x86_64')
+url="https://bitbucket.org/Thesilentdrifter/tutanota-electron"
+licence=('BSD')
+depends=('gulp-cli' 'npm')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=()
+changeLog=()
+source=("https://bitbucket.org/Thesilentdrifter/tutanota-electron/raw/9a7e8dd0c44f5f43e931a79556512bffe9415431/tutanota-electron-git.tar.gz")
+md5sums=(51466202ad0c301f5d3605b7226cfa4b)
+sha512sums=(639b841f8a668514bcdac1c4f16a6ae35d5e81a25d1fc09291a0a5b2eb7a6fa9d19346ab8baaeffb5bfbad3c7485d243f9a5b534fe20332375fd3c3b2474b42b)
+
+build() {
+ cd "$pkgname"
+ ./build.sh
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/$pkgname/"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -r "${srcdir}/${pkgname}/releases/tutanota-linux-x64/" "${pkgdir}/opt/$pkgname"
+ install -Dm644 "$srcdir/$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ ln -s /opt/tutanota-electron/tutanota-linux-x64/tutanota "${pkgdir}/usr/bin/tutanota"
+ install -Dm755 "$srcdir/$pkgname/tutanota.desktop" "${pkgdir}/usr/share/applications/tutanota.desktop"
+}
diff --git a/tutanota-electron-git.install b/tutanota-electron-git.install
new file mode 100644
index 000000000000..43ae2f13e2a3
--- /dev/null
+++ b/tutanota-electron-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgarde() {
+ post_install
+}