summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-20 16:45:58 +0300
committerDimitris Kiziridis2020-06-20 16:45:58 +0300
commit87a779f1963efb22f172844f555db63ad9f2921a (patch)
tree169dfb781d107c803027a892d2e0ebeb8a4ca56d
downloadaur-87a779f1963efb22f172844f555db63ad9f2921a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdf66bf3e018
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tutti-quanti-shelf
+ pkgdesc = Collection of miscellaneous developer-oriented utilities wrapped into one single app, built with Electron
+ pkgver = 1.13.1
+ pkgrel = 1
+ url = https://github.com/tonton-pixel/tutti-quanti-shelf
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ makedepends = gendesk
+ depends = nss
+ depends = libxss
+ depends = gtk3
+ source = tutti-quanti-shelf-1.13.1.tar.gz::https://github.com/tonton-pixel/tutti-quanti-shelf/archive/v1.13.1.tar.gz
+ sha256sums = 23d3d2a1e91302da82f7378cd3354f1faee1281f42751df4efc4cce6def3097e
+
+pkgname = tutti-quanti-shelf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9847298d9696
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=tutti-quanti-shelf
+pkgver=1.13.1
+pkgrel=1
+pkgdesc="Collection of miscellaneous developer-oriented utilities wrapped into one single app, built with Electron"
+arch=('x86_64')
+url='https://github.com/tonton-pixel/tutti-quanti-shelf'
+license=('MIT')
+depends=('nss'
+ 'libxss'
+ 'gtk3')
+makedepends=('npm' 'gendesk')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tonton-pixel/tutti-quanti-shelf/archive/v${pkgver}.tar.gz")
+sha256sums=('23d3d2a1e91302da82f7378cd3354f1faee1281f42751df4efc4cce6def3097e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ rm -rf "${srcdir}/npm-cache"
+ mkdir ${srcdir}/npm-cache
+ npm install --cache "${srcdir}/npm-cache"
+ npm run build-linux
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/opt" "${pkgdir}/usr/bin"
+ cp -R "build/Tutti Quanti Shelf-linux-x64" "${pkgdir}/opt/${pkgname}"
+ ln -sf "/opt/${pkgname}/Tutti Quanti Shelf" "${pkgdir}/usr/bin/${pkgname}"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Tutti Quanti Shelf" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Utility;Development;Application;' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 icons/icon-256.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+} \ No newline at end of file