summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Seifried2020-01-07 20:04:02 +0100
committerSteven Seifried2020-01-07 20:04:02 +0100
commit38d773299150996cadbe13ddda7b53200bf81eba (patch)
tree1094d56ae035b7856ad9e72bd7f40361a70f06c8
parente99f4ab8e7f2c688ab9d18d74c1788f96f4df050 (diff)
downloadaur-38d773299150996cadbe13ddda7b53200bf81eba.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--tuxedo-keyboard.install18
3 files changed, 16 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b6173d6c8e6..5cc15194b09e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = tuxedo-keyboard
pkgdesc = Keyboard Backlight Driver from TUXEDO Computers
pkgver = 2.0.0
- pkgrel = 10
+ pkgrel = 11
url = https://github.com/tuxedocomputers/tuxedo-keyboard
- install = tuxedo-keyboard.install
arch = x86_64
license = GPL
- makedepends = gcc
- makedepends = make
- depends = git
+ makedepends = git
depends = dkms
- depends = linux-headers
+ optdepends = linux-headers: build modules against Arch kernel
+ optdepends = linux-lts-headers: build modules against LTS kernel
+ optdepends = linux-zen-headers: build modules against ZEN kernel
conflicts = tuxedo-keyboard-dkms
conflicts = tuxedo-wmi
conflicts = tuxedo-wmi-dkms
replaces = tuxedo-keyboard-dkms
+ backup = etc/modprobe.d/tuxedo_keyboard.conf
source = git+https://github.com/tuxedocomputers/tuxedo-keyboard.git
source = tuxedokeyboard.conf
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 06711a0cf950..51d92d663074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,29 @@
# Contributor: Steven Seifried <gitlab@canox.net>
pkgname=tuxedo-keyboard
pkgver=2.0.0
-pkgrel=10
+pkgrel=11
pkgdesc="Keyboard Backlight Driver from TUXEDO Computers"
url="https://github.com/tuxedocomputers/tuxedo-keyboard"
license=("GPL")
arch=('x86_64')
-makedepends=('gcc' 'make')
-depends=('git' 'dkms' 'linux-headers')
+makedepends=('git')
+depends=('dkms')
conflicts=('tuxedo-keyboard-dkms' 'tuxedo-wmi' 'tuxedo-wmi-dkms')
+optdepends=('linux-headers: build modules against Arch kernel'
+ 'linux-lts-headers: build modules against LTS kernel'
+ 'linux-zen-headers: build modules against ZEN kernel')
replaces=('tuxedo-keyboard-dkms')
+backup=(etc/modprobe.d/tuxedo_keyboard.conf)
source=('git+https://github.com/tuxedocomputers/tuxedo-keyboard.git' 'tuxedokeyboard.conf')
sha256sums=('SKIP' 'd22aadf76a400f38ddee7ce2fd7f8b14694bf1d402bfbb99e65133d122ccb0f8')
sha512sums=('SKIP' '8aef78240aacf4a5c15cfb648400750a17db3203d230d6a1f8a84b1db71f0bd0d65251690f6290d8707b771cf74c6f008b82c65b00220e8d3fa70153be65ade6')
-install="tuxedo-keyboard.install"
package() {
mkdir -p "${pkgdir}/usr/src/${pkgname}-${pkgver}"
cp -r "${srcdir}/${pkgname}"/* "${pkgdir}/usr/src/${pkgname}-${pkgver}"
+ sed -i "s/^KDIR.*$//g" "${pkgdir}/usr/src/${pkgname}-${pkgver}/Makefile"
+ sed -i "s/KDIR/KERNELDIR/g" "${pkgdir}/usr/src/${pkgname}-${pkgver}/Makefile"
install -D "${srcdir}/${pkgname}/dkms.conf" "${pkgdir}/usr/src/${pkgname}-${pkgver}/dkms.conf"
echo "Copy tuxedo_keyboard.conf to /etc/modprobe.d/tuxedo_keyboard.conf"
install -Dm644 "${srcdir}/${pkgname}/tuxedo_keyboard.conf" "${pkgdir}/etc/modprobe.d/tuxedo_keyboard.conf"
- install -Dm644 ${srcdir}/tuxedokeyboard.conf ${pkgdir}/etc/modules-load.d/${pkgname}.conf
+ install -Dm644 ${srcdir}/tuxedokeyboard.conf ${pkgdir}/usr/lib/modules-load.d/${pkgname}.conf
}
diff --git a/tuxedo-keyboard.install b/tuxedo-keyboard.install
deleted file mode 100644
index 36dfd7cecc4c..000000000000
--- a/tuxedo-keyboard.install
+++ /dev/null
@@ -1,18 +0,0 @@
-# old version (without -$pkgrel): ${1%%-*}
-# new version (without -$pkgrel): ${2%%-*}
-
-post_install() {
- dkms install tuxedo-keyboard/${1%%-*}
-}
-
-pre_upgrade() {
- pre_remove ${2%%-*}
-}
-
-post_upgrade() {
- post_install ${1%%-*}
-}
-
-pre_remove() {
- dkms remove tuxedo-keyboard/${1%%-*} --all
-}