summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrainpower2021-03-07 23:25:43 +0100
committerbrainpower2021-03-07 23:25:43 +0100
commit38f2645be456a5f8a3cb7e6bd522bf1a52f505c2 (patch)
treedfe733a8f290a59d0b1a4e80ba304e033168e7b5
downloadaur-38f2645be456a5f8a3cb7e6bd522bf1a52f505c2.tar.gz
Initial upload: tuxedo-touchpad-switch 1.0.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee2abba2fa6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tuxedo-touchpad-switch
+ pkgdesc = A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/tuxedocomputers/tuxedo-touchpad-switch
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ depends = glib2
+ provides = tuxedo-touchpad-switch
+ conflicts = tuxedo-touchpad-switch
+ source = git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=3f90c9c6c1e51f6d8538877d2f15677ce39b167b
+ sha256sums = SKIP
+
+pkgname = tuxedo-touchpad-switch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80bef8779439
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: oi_wtf <brainpower at mailbox dot org>
+
+pkgname=tuxedo-touchpad-switch
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops"
+url="https://github.com/tuxedocomputers/tuxedo-touchpad-switch"
+arch=(x86_64)
+license=(GPL3)
+
+depends=("glib2")
+makedepends=("git" "cmake" "ninja")
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+#https://github.com/tuxedocomputers/tuxedo-touchpad-switch/archive/v$pkgver/${pkgname}-${pkgver}.tar.gz
+source=(
+ git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=3f90c9c6c1e51f6d8538877d2f15677ce39b167b
+)
+sha256sums=(SKIP)
+#sha256sums=('dd4fa6871735fed3e094f177f0a2d0861fd3411ef4e6fbf1fbba5405a01ae219')
+
+build() {
+ cd "${pkgname}"
+
+ cmake -B builddir -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+
+ ninja -C builddir
+}
+
+package() {
+ cd "${pkgname}"
+
+ DESTDIR="${pkgdir}" ninja -C builddir install
+}