summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrainpower2022-02-17 11:44:19 +0100
committerbrainpower2022-02-17 11:44:19 +0100
commitaed4ff00412cf3188dd72e42d3f7fa546f83e11f (patch)
tree6b0f6b00cf3842766e7fb293cabf638b569d1ff9
parent2ad6c21c17e64e4c5f044c9ab0e9d16e186c434e (diff)
downloadaur-aed4ff00412cf3188dd72e42d3f7fa546f83e11f.tar.gz
upgpkg: tuxedo-touchpad-switch 1.0.3-2
add fix for plasma 5.24
-rw-r--r--.SRCINFO4
-rw-r--r--0001-plasma_5-24.patch13
-rw-r--r--PKGBUILD16
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72e5ee394d76..41915c6acd82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tuxedo-touchpad-switch
pkgdesc = A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops
pkgver = 1.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tuxedocomputers/tuxedo-touchpad-switch
arch = x86_64
license = GPL3
@@ -12,6 +12,8 @@ pkgbase = tuxedo-touchpad-switch
provides = tuxedo-touchpad-switch
conflicts = tuxedo-touchpad-switch
source = git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=88c8e4561087a3c7e8bf60bdd72a1f0005864eb0
+ source = 0001-plasma_5-24.patch
sha256sums = SKIP
+ sha256sums = 5f9f5e02c2913ea16936961c4bd02ad444123d0a6cc441fa8f5cab9b5f905b7b
pkgname = tuxedo-touchpad-switch
diff --git a/0001-plasma_5-24.patch b/0001-plasma_5-24.patch
new file mode 100644
index 000000000000..8c6e7d7f0687
--- /dev/null
+++ b/0001-plasma_5-24.patch
@@ -0,0 +1,13 @@
+diff --git a/setup-kde.cpp b/setup-kde.cpp
+index 903096f..fcbcb82 100644
+--- a/setup-kde.cpp
++++ b/setup-kde.cpp
+@@ -165,7 +165,7 @@ int setup_kde(int lockfile_arg) {
+ GDBusProxy *kded5_modules_touchpad = g_dbus_proxy_new_for_bus_sync(G_BUS_TYPE_SESSION,
+ G_DBUS_PROXY_FLAGS_NONE, NULL,
+ "org.kde.kded5",
+- "/modules/touchpad",
++ "/modules/kded_touchpad",
+ "org.kde.touchpad",
+ NULL, NULL);
+ if (kded5_modules_touchpad == NULL) {
diff --git a/PKGBUILD b/PKGBUILD
index 6724fdc85d99..2f446370ab14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=tuxedo-touchpad-switch
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Linux userspace driver to enable and disable the touchpads on TongFang/Uniwill laptops"
url="https://github.com/tuxedocomputers/tuxedo-touchpad-switch"
arch=(x86_64)
@@ -18,13 +18,19 @@ _commit="88c8e4561087a3c7e8bf60bdd72a1f0005864eb0"
#https://github.com/tuxedocomputers/tuxedo-touchpad-switch/archive/v$pkgver/${pkgname}-${pkgver}.tar.gz
source=(
git+https://github.com/tuxedocomputers/tuxedo-touchpad-switch.git#commit=$_commit
+ 0001-plasma_5-24.patch
+)
+sha256sums=(
+ SKIP
+ 5f9f5e02c2913ea16936961c4bd02ad444123d0a6cc441fa8f5cab9b5f905b7b
)
-sha256sums=(SKIP)
#sha256sums=('dd4fa6871735fed3e094f177f0a2d0861fd3411ef4e6fbf1fbba5405a01ae219')
-#prepare() {
-# cd "${pkgname}"
-#}
+prepare() {
+ cd "${pkgname}"
+
+ patch -p1 -i "${srcdir}/0001-plasma_5-24.patch"
+}
build() {
cd "${pkgname}"