summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2022-01-19 22:14:12 +0100
committermorguldir2022-01-19 22:14:12 +0100
commitb0804f8c003c40b787d010fe07fd447f20696add (patch)
treeb92a593ece768edd17cd6c22060995069a3cf95e
parent6a02b20c649bd8dbe9003efb61d7cdd14aea16e3 (diff)
downloadaur-b0804f8c003c40b787d010fe07fd447f20696add.tar.gz
Update pkgver() function, you may want to downgrade
-rw-r--r--PKGBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fd2c0f68698..7ada2cda0e91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,7 @@ sha256sums=('SKIP')
pkgver() {
cd $pkgname
-
- _info="$(git blame -s README.md|grep 'Tuxemon [0-9].[0-9].[0-9]')"
- _version="$(echo $_info | awk '{print $4}')"
- _commit="$(echo $_info | awk '{print $1}')"
- _revisions="$(git rev-list --count $_commit..HEAD)"
- _current_commit="$(git log --pretty=format:'%h' -n 1)"
-
- printf "%s.r%d.g%s" $_version $_revisions $_current_commit
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {