summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVisne2024-04-15 23:40:20 +0200
committerVisne2024-04-15 23:40:20 +0200
commitc0bf8c0e91fe3b39435e06ec48b702835a6d31f6 (patch)
treec669b4a95b8395612cf98e146c28da752204a773
parente6ff96b367583e225e4a172134c817b010fa980f (diff)
downloadaur-tuxguitar.tar.gz
Minor cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1782c2b62101..ae7970a8e176 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,7 +28,7 @@ pkgbase = tuxguitar
optdepends = lilypond: Compile exported LilyPond files
replaces = tuxguitar-common
replaces = tuxguitar-gtk2
- source = tuxguitar-1.6.2::https://github.com/helge17/tuxguitar/archive/refs/tags/1.6.2.zip
+ source = tuxguitar-1.6.2.zip::https://github.com/helge17/tuxguitar/archive/refs/tags/1.6.2.zip
sha256sums = d0d8e8f64240379e8fc8f83dcdfd220f9c105dcc2879b56f6f1c3ad4ce256a11
pkgname = tuxguitar
diff --git a/PKGBUILD b/PKGBUILD
index 25a728f5ef1f..7909a34b7721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,18 +22,15 @@ optdepends=('fluidsynth: FluidSynth plugin support'
'jack: Jack plugin support'
'lilypond: Compile exported LilyPond files')
replaces=('tuxguitar-common' 'tuxguitar-gtk2')
-source=("tuxguitar-$pkgver::https://github.com/helge17/tuxguitar/archive/refs/tags/$pkgver.zip")
+source=("tuxguitar-$pkgver.zip::https://github.com/helge17/tuxguitar/archive/refs/tags/$pkgver.zip")
sha256sums=('d0d8e8f64240379e8fc8f83dcdfd220f9c105dcc2879b56f6f1c3ad4ce256a11')
prepare() {
- cd tuxguitar-$pkgver
-
export MAVEN_OPTS="$MAVEN_OPTS -Duser.home=$srcdir"
# Install SWT manually (see https://github.com/helge17/tuxguitar/blob/1.6.2/INSTALL.md#download-and-install-swt-for-linux)
- mkdir swt && cd swt
wget https://archive.eclipse.org/eclipse/downloads/drops4/R-4.26-202211231800/swt-4.26-gtk-linux-x86_64.zip -O swt.zip
- unzip -o swt.zip
+ unzip -o swt.zip swt.jar
# Lie about version to fix wayland bug https://github.com/helge17/tuxguitar/issues/323
mvn install:install-file -Dfile=swt.jar -DgroupId=org.eclipse.swt -DartifactId=org.eclipse.swt.gtk.linux.x86_64 -Dpackaging=jar -Dversion=4.13
}