summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthanosapostolou2018-12-14 18:28:41 +0200
committerthanosapostolou2018-12-14 18:38:40 +0200
commit46a93ed95219a5fa5e49bf152fd85a2693e45eab (patch)
tree047ab5749a20a832f66433aaf915474e5fad786f
parent23e8f01a66a74f54b05c8fe2fef717cbc1ee94ce (diff)
downloadaur-46a93ed95219a5fa5e49bf152fd85a2693e45eab.tar.gz
Use gtk3 by default, provide -gtk2 alternative
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
-rwxr-xr-xtuxguitar3
-rwxr-xr-xtuxguitar-gtk23
4 files changed, 62 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42aae4430a76..95b707400874 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tuxguitar
pkgdesc = multitrack guitar tablature editor and player
pkgver = 1.5.2
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/projects/tuxguitar
arch = x86_64
license = LGPL
@@ -14,13 +14,27 @@ pkgbase = tuxguitar
makedepends = maven
depends = java-runtime>=8
depends = alsa-lib
- depends = gtk2
depends = libxtst
optdepends = fluidsynth
source = https://downloads.sourceforge.net/tuxguitar/tuxguitar-1.5.2-src.tar.gz
source = nogcj.patch
+ source = tuxguitar
+ source = tuxguitar-gtk2
sha256sums = a9ade566752aa0ac72831a1cd0b18b85d302eca7934e2192ad875f51df755981
sha256sums = bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc
+ sha256sums = efeef39d43ecf5a87ed64abc7d8cf63a01f3c9b08bac0ea299bf959fcb7c216a
+ sha256sums = 39f92c0de6fcf86635dec5ac3b83613ca980fa7d24f66888fd06e5bb2c7c571f
pkgname = tuxguitar
+ depends = tuxguitar-common
+ depends = gtk3
+ replaces = tuxguitar-gtk3
+
+pkgname = tuxguitar-common
+
+pkgname = tuxguitar-gtk2
+ depends = tuxguitar-common
+ depends = gtk2
+ provides = tuxguitar
+ conflicts = tuxguitar
diff --git a/PKGBUILD b/PKGBUILD
index 60cb7a0ac1c7..8d2cd6f25fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: Alexandre Moine <alexandre@moine.me>
+# Maintainer: Thanos Apostolou <thanosapostolou@outlook.com>
+# Contributor: Alexandre Moine <alexandre@moine.me>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: |AhIoRoS| < ahioros@gmail.com >
-pkgname=tuxguitar
+pkgbase=tuxguitar
+pkgname=(tuxguitar tuxguitar-common tuxguitar-gtk2)
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="multitrack guitar tablature editor and player"
arch=('x86_64')
url="http://sourceforge.net/projects/tuxguitar"
license=('LGPL')
-depends=('java-runtime>=8' 'alsa-lib' 'gtk2' 'libxtst')
+depends=('java-runtime>=8' 'alsa-lib' 'libxtst')
makedepends=('unzip' 'zip' 'apache-ant' 'jack' 'fluidsynth' 'java-environment>=8' 'maven')
optdepends=('fluidsynth')
source=(https://downloads.sourceforge.net/tuxguitar/tuxguitar-$pkgver-src.tar.gz
- nogcj.patch)
+ nogcj.patch
+ tuxguitar
+ tuxguitar-gtk2)
sha256sums=('a9ade566752aa0ac72831a1cd0b18b85d302eca7934e2192ad875f51df755981'
- 'bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc')
+ 'bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc'
+ 'efeef39d43ecf5a87ed64abc7d8cf63a01f3c9b08bac0ea299bf959fcb7c216a'
+ '39f92c0de6fcf86635dec5ac3b83613ca980fa7d24f66888fd06e5bb2c7c571f')
case $CARCH in
i686) _arch=x86;;
@@ -48,7 +54,7 @@ build() {
); done
}
-package() {
+package_tuxguitar-common () {
# tuxguitar
cd tuxguitar-$pkgver-src/build-scripts
install -d "$pkgdir"/usr/share
@@ -65,17 +71,33 @@ package() {
for _m in audio-x-{tuxguitar,gtp,ptb}; do
ln -sr "$_dir"/apps/tuxguitar.png "$_dir"/mimetypes/$_m.png
done
- done
+ done
+
+ #misc
+ cd "${srcdir}/tuxguitar-$pkgver-src/misc"
+ install -Dm644 tuxguitar.xml "$pkgdir"/usr/share/mime/packages/tuxguitar.xml
+ install -Dm644 tuxguitar.desktop "$pkgdir"/usr/share/applications/tuxguitar.desktop
+
+ # remove tuxguitar.sh
+ rm "${pkgdir}/usr/share/tuxguitar/tuxguitar.sh"
+}
- # Misc
- install -Dm644 misc/tuxguitar.xml "$pkgdir"/usr/share/mime/packages/tuxguitar.xml
- install -Dm644 misc/tuxguitar.desktop "$pkgdir"/usr/share/applications/tuxguitar.desktop
+package_tuxguitar () {
+ depends=('tuxguitar-common' 'gtk3')
+ replaces=('tuxguitar-gtk3')
+
+ install -Dm 755 tuxguitar "$pkgdir"/usr/bin/tuxguitar
+ install -Dm 755 "${srcdir}/tuxguitar-$pkgver-src/build-scripts/tuxguitar-linux-$_arch/target/tuxguitar-$pkgver-linux-$_arch/tuxguitar.sh" \
+ "${pkgdir}/usr/share/tuxguitar/tuxguitar.sh"
+ sed -i s/SWT_GTK3=0/SWT_GTK3=1/g "${pkgdir}/usr/share/tuxguitar/tuxguitar.sh"
+}
- # Launcher
- install -D /dev/stdin "$pkgdir"/usr/bin/tuxguitar <<EOF
-#!/bin/sh -e
-export SWT_GTK3=0
-cd /usr/share/tuxguitar
-exec ./tuxguitar.sh -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false "\$@"
-EOF
+package_tuxguitar-gtk2 () {
+ depends=('tuxguitar-common' 'gtk2')
+ conflicts=('tuxguitar')
+ provides=('tuxguitar')
+
+ install -Dm 755 tuxguitar-gtk2 "$pkgdir"/usr/bin/tuxguitar
+ install -Dm 755 "${srcdir}/tuxguitar-$pkgver-src/build-scripts/tuxguitar-linux-$_arch/target/tuxguitar-$pkgver-linux-$_arch/tuxguitar.sh" \
+ "${pkgdir}/usr/share/tuxguitar/tuxguitar.sh"
}
diff --git a/tuxguitar b/tuxguitar
new file mode 100755
index 000000000000..1940436bc378
--- /dev/null
+++ b/tuxguitar
@@ -0,0 +1,3 @@
+#!/bin/sh -e
+cd /usr/share/tuxguitar
+exec ./tuxguitar.sh "$@"
diff --git a/tuxguitar-gtk2 b/tuxguitar-gtk2
new file mode 100755
index 000000000000..6c7851215437
--- /dev/null
+++ b/tuxguitar-gtk2
@@ -0,0 +1,3 @@
+#!/bin/sh -e
+cd /usr/share/tuxguitar
+exec ./tuxguitar.sh -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false "$@"