summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThanos Apostolou2019-03-20 16:04:43 +0200
committerThanos Apostolou2019-03-20 16:04:43 +0200
commita4945997b21a2b5d6d14858560a9bdd3a678bba3 (patch)
treea0ea65bbedc2f8c726999ef4cc695aa1fae87d60
parentdfa36e1bdc1ca0d3246a7395a85d2b222b8e8e24 (diff)
downloadaur-a4945997b21a2b5d6d14858560a9bdd3a678bba3.tar.gz
clean pkgbuild
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
-rw-r--r--nogcj.patch168
3 files changed, 14 insertions, 190 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e3944767802..5b2da42edd06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = tuxguitar
pkgdesc = multitrack guitar tablature editor and player
pkgver = 1.5.2_r1800
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/projects/tuxguitar
arch = x86_64
license = LGPL
makedepends = unzip
makedepends = zip
- makedepends = apache-ant
+ makedepends = ant
makedepends = jack
makedepends = fluidsynth
makedepends = java-environment>=8
@@ -17,12 +17,10 @@ pkgbase = tuxguitar
depends = alsa-lib
depends = libxtst
optdepends = fluidsynth
- source = tuxguitar-1.5.2_r1800-src::svn+svn://svn.code.sf.net/p/tuxguitar/code/trunk@r1800
- source = nogcj.patch
+ source = tuxguitar-1.5.2_r1800-svn::svn+svn://svn.code.sf.net/p/tuxguitar/code/trunk@r1800
source = tuxguitar
source = tuxguitar-gtk2
sha256sums = SKIP
- sha256sums = bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc
sha256sums = efeef39d43ecf5a87ed64abc7d8cf63a01f3c9b08bac0ea299bf959fcb7c216a
sha256sums = 39f92c0de6fcf86635dec5ac3b83613ca980fa7d24f66888fd06e5bb2c7c571f
diff --git a/PKGBUILD b/PKGBUILD
index 272d39938c38..585ca5a94818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,19 @@
pkgbase=tuxguitar
pkgname=(tuxguitar tuxguitar-common tuxguitar-gtk2)
pkgver=1.5.2_r1800
-pkgrel=1
+pkgrel=2
pkgdesc="multitrack guitar tablature editor and player"
arch=('x86_64')
url="http://sourceforge.net/projects/tuxguitar"
license=('LGPL')
depends=('java-runtime>=8' 'alsa-lib' 'libxtst')
-makedepends=('unzip' 'zip' 'apache-ant' 'jack' 'fluidsynth' 'java-environment>=8' 'maven' 'subversion')
+makedepends=('unzip' 'zip' 'ant' 'jack' 'fluidsynth' 'java-environment>=8' 'maven' 'subversion')
optdepends=('fluidsynth')
-source=(tuxguitar-${pkgver}-src::svn+svn://svn.code.sf.net/p/tuxguitar/code/trunk@r1800
- nogcj.patch
+#source=(https://downloads.sourceforge.net/tuxguitar/tuxguitar-$pkgver-src.tar.gz)
+source=(tuxguitar-${pkgver}-svn::svn+svn://svn.code.sf.net/p/tuxguitar/code/trunk@r1800
tuxguitar
tuxguitar-gtk2)
-#source=(https://downloads.sourceforge.net/tuxguitar/tuxguitar-$pkgver-src.tar.gz)
sha256sums=('SKIP'
- 'bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc'
'efeef39d43ecf5a87ed64abc7d8cf63a01f3c9b08bac0ea299bf959fcb7c216a'
'39f92c0de6fcf86635dec5ac3b83613ca980fa7d24f66888fd06e5bb2c7c571f')
@@ -31,25 +29,21 @@ case $CARCH in
esac
prepare() {
- cd tuxguitar-$pkgver-src
- # fix version when building from svn checkout
- for i in $(find . -name "pom.xml")
- do
- sed -i s/SNAPSHOT/${pkgver}/g $i
- done
-# patch -Np1 -i ../nogcj.patch
+ cd tuxguitar-$pkgver-svn/build-scripts/tuxguitar-src
+ ant -Ddist.version=${pkgver}
+ mv target/tuxguitar-${pkgver}-src ${srcdir}
}
build() {
+ cd tuxguitar-$pkgver-src
export MAVEN_OPTS="$MAVEN_OPTS -Duser.home=$srcdir"
export JAVA_HOME="/usr/lib/jvm/"`archlinux-java get`
- cd tuxguitar-$pkgver-src
- for _i in . TuxGuitar-{lib,gm-utils} \
- build-scripts/{tuxguitar,native-modules/tuxguitar-{alsa,oss,jack,fluidsynth}}-linux-$_arch
+ mvn clean install -P platform-linux-$_arch
+ for _i in build-scripts/{tuxguitar,native-modules/tuxguitar-{alsa,oss,jack,fluidsynth}}-linux-$_arch
do (
cd $_i
- mvn install
+ mvn clean install
); done
}
diff --git a/nogcj.patch b/nogcj.patch
deleted file mode 100644
index d312cb81ae7f..000000000000
--- a/nogcj.patch
+++ /dev/null
@@ -1,168 +0,0 @@
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml 2017-02-08 22:06:28.220720753 +0100
-@@ -22,8 +22,8 @@
-
- <tuxguitar-alsa.jni.path>${parent.relativePath}/TuxGuitar-alsa/jni/</tuxguitar-alsa.jni.path>
- <tuxguitar-alsa.jni.cc>${tuxguitar.jni.cc}</tuxguitar-alsa.jni.cc>
-- <tuxguitar-alsa.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-alsa.jni.cflags>
-- <tuxguitar-alsa.jni.ldflags>-fPIC</tuxguitar-alsa.jni.ldflags>
-+ <tuxguitar-alsa.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-alsa.jni.cflags>
-+ <tuxguitar-alsa.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-alsa.jni.ldflags>
- <tuxguitar-alsa.jni.ldlibs>-lasound</tuxguitar-alsa.jni.ldlibs>
- <tuxguitar-alsa.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-alsa.jni.ldpath>
- <tuxguitar-alsa.jni.library.name>tuxguitar-alsa-jni</tuxguitar-alsa.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml 2017-02-08 22:06:28.220720753 +0100
-@@ -22,8 +22,8 @@
-
- <tuxguitar-alsa.jni.path>${parent.relativePath}/TuxGuitar-alsa/jni/</tuxguitar-alsa.jni.path>
- <tuxguitar-alsa.jni.cc>${tuxguitar.jni.cc}</tuxguitar-alsa.jni.cc>
-- <tuxguitar-alsa.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-alsa.jni.cflags>
-- <tuxguitar-alsa.jni.ldflags>-m32 -fPIC</tuxguitar-alsa.jni.ldflags>
-+ <tuxguitar-alsa.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-alsa.jni.cflags>
-+ <tuxguitar-alsa.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-alsa.jni.ldflags>
- <tuxguitar-alsa.jni.ldlibs>-lasound</tuxguitar-alsa.jni.ldlibs>
- <tuxguitar-alsa.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-alsa.jni.ldpath>
- <tuxguitar-alsa.jni.library.name>tuxguitar-alsa-jni</tuxguitar-alsa.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml 2017-02-08 22:06:28.220720753 +0100
-@@ -22,8 +22,8 @@
-
- <tuxguitar-alsa.jni.path>${parent.relativePath}/TuxGuitar-alsa/jni/</tuxguitar-alsa.jni.path>
- <tuxguitar-alsa.jni.cc>${tuxguitar.jni.cc}</tuxguitar-alsa.jni.cc>
-- <tuxguitar-alsa.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-alsa.jni.cflags>
-- <tuxguitar-alsa.jni.ldflags>-m64 -fPIC</tuxguitar-alsa.jni.ldflags>
-+ <tuxguitar-alsa.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-alsa.jni.cflags>
-+ <tuxguitar-alsa.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-alsa.jni.ldflags>
- <tuxguitar-alsa.jni.ldlibs>-lasound</tuxguitar-alsa.jni.ldlibs>
- <tuxguitar-alsa.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-alsa.jni.ldpath>
- <tuxguitar-alsa.jni.library.name>tuxguitar-alsa-jni</tuxguitar-alsa.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml 2017-02-08 22:06:28.220720753 +0100
-@@ -24,8 +24,8 @@
- <tuxguitar-fluidsynth.jni.path>${parent.relativePath}/TuxGuitar-fluidsynth/jni/</tuxguitar-fluidsynth.jni.path>
- <tuxguitar-fluidsynth.jni.rm>${tuxguitar.jni.rm}</tuxguitar-fluidsynth.jni.rm>
- <tuxguitar-fluidsynth.jni.cc>${tuxguitar.jni.cc}</tuxguitar-fluidsynth.jni.cc>
-- <tuxguitar-fluidsynth.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-fluidsynth.jni.cflags>
-- <tuxguitar-fluidsynth.jni.ldflags>-fPIC</tuxguitar-fluidsynth.jni.ldflags>
-+ <tuxguitar-fluidsynth.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-fluidsynth.jni.cflags>
-+ <tuxguitar-fluidsynth.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-fluidsynth.jni.ldflags>
- <tuxguitar-fluidsynth.jni.ldlibs>-lfluidsynth</tuxguitar-fluidsynth.jni.ldlibs>
- <tuxguitar-fluidsynth.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-fluidsynth.jni.ldpath>
- <tuxguitar-fluidsynth.jni.library.name>tuxguitar-fluidsynth-jni</tuxguitar-fluidsynth.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -24,8 +24,8 @@
- <tuxguitar-fluidsynth.jni.path>${parent.relativePath}/TuxGuitar-fluidsynth/jni/</tuxguitar-fluidsynth.jni.path>
- <tuxguitar-fluidsynth.jni.rm>${tuxguitar.jni.rm}</tuxguitar-fluidsynth.jni.rm>
- <tuxguitar-fluidsynth.jni.cc>${tuxguitar.jni.cc}</tuxguitar-fluidsynth.jni.cc>
-- <tuxguitar-fluidsynth.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-fluidsynth.jni.cflags>
-- <tuxguitar-fluidsynth.jni.ldflags>-m32 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
-+ <tuxguitar-fluidsynth.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-fluidsynth.jni.cflags>
-+ <tuxguitar-fluidsynth.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
- <tuxguitar-fluidsynth.jni.ldlibs>-lfluidsynth</tuxguitar-fluidsynth.jni.ldlibs>
- <tuxguitar-fluidsynth.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-fluidsynth.jni.ldpath>
- <tuxguitar-fluidsynth.jni.library.name>tuxguitar-fluidsynth-jni</tuxguitar-fluidsynth.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -24,8 +24,8 @@
- <tuxguitar-fluidsynth.jni.path>${parent.relativePath}/TuxGuitar-fluidsynth/jni/</tuxguitar-fluidsynth.jni.path>
- <tuxguitar-fluidsynth.jni.rm>${tuxguitar.jni.rm}</tuxguitar-fluidsynth.jni.rm>
- <tuxguitar-fluidsynth.jni.cc>${tuxguitar.jni.cc}</tuxguitar-fluidsynth.jni.cc>
-- <tuxguitar-fluidsynth.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-fluidsynth.jni.cflags>
-- <tuxguitar-fluidsynth.jni.ldflags>-m64 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
-+ <tuxguitar-fluidsynth.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-fluidsynth.jni.cflags>
-+ <tuxguitar-fluidsynth.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
- <tuxguitar-fluidsynth.jni.ldlibs>-lfluidsynth</tuxguitar-fluidsynth.jni.ldlibs>
- <tuxguitar-fluidsynth.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-fluidsynth.jni.ldpath>
- <tuxguitar-fluidsynth.jni.library.name>tuxguitar-fluidsynth-jni</tuxguitar-fluidsynth.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -24,8 +24,8 @@
- <tuxguitar-jack.jni.path>${parent.relativePath}/TuxGuitar-jack/jni/</tuxguitar-jack.jni.path>
- <tuxguitar-jack.jni.rm>${tuxguitar.jni.rm}</tuxguitar-jack.jni.rm>
- <tuxguitar-jack.jni.cc>${tuxguitar.jni.cc}</tuxguitar-jack.jni.cc>
-- <tuxguitar-jack.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-jack.jni.cflags>
-- <tuxguitar-jack.jni.ldflags>-fPIC</tuxguitar-jack.jni.ldflags>
-+ <tuxguitar-jack.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-jack.jni.cflags>
-+ <tuxguitar-jack.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-jack.jni.ldflags>
- <tuxguitar-jack.jni.ldlibs>`pkg-config --libs jack`</tuxguitar-jack.jni.ldlibs>
- <tuxguitar-jack.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-jack.jni.ldpath>
- <tuxguitar-jack.jni.library.name>tuxguitar-jack-jni</tuxguitar-jack.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -24,8 +24,8 @@
- <tuxguitar-jack.jni.path>${parent.relativePath}/TuxGuitar-jack/jni/</tuxguitar-jack.jni.path>
- <tuxguitar-jack.jni.rm>${tuxguitar.jni.rm}</tuxguitar-jack.jni.rm>
- <tuxguitar-jack.jni.cc>${tuxguitar.jni.cc}</tuxguitar-jack.jni.cc>
-- <tuxguitar-jack.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-jack.jni.cflags>
-- <tuxguitar-jack.jni.ldflags>-m32 -fPIC</tuxguitar-jack.jni.ldflags>
-+ <tuxguitar-jack.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-jack.jni.cflags>
-+ <tuxguitar-jack.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-jack.jni.ldflags>
- <tuxguitar-jack.jni.ldlibs>`pkg-config --libs jack`</tuxguitar-jack.jni.ldlibs>
- <tuxguitar-jack.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-jack.jni.ldpath>
- <tuxguitar-jack.jni.library.name>tuxguitar-jack-jni</tuxguitar-jack.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -24,8 +24,8 @@
- <tuxguitar-jack.jni.path>${parent.relativePath}/TuxGuitar-jack/jni/</tuxguitar-jack.jni.path>
- <tuxguitar-jack.jni.rm>${tuxguitar.jni.rm}</tuxguitar-jack.jni.rm>
- <tuxguitar-jack.jni.cc>${tuxguitar.jni.cc}</tuxguitar-jack.jni.cc>
-- <tuxguitar-jack.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-jack.jni.cflags>
-- <tuxguitar-jack.jni.ldflags>-m64 -fPIC</tuxguitar-jack.jni.ldflags>
-+ <tuxguitar-jack.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-jack.jni.cflags>
-+ <tuxguitar-jack.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-jack.jni.ldflags>
- <tuxguitar-jack.jni.ldlibs>`pkg-config --libs jack`</tuxguitar-jack.jni.ldlibs>
- <tuxguitar-jack.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-jack.jni.ldpath>
- <tuxguitar-jack.jni.library.name>tuxguitar-jack-jni</tuxguitar-jack.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -22,8 +22,8 @@
-
- <tuxguitar-oss.jni.path>${parent.relativePath}/TuxGuitar-oss/jni/</tuxguitar-oss.jni.path>
- <tuxguitar-oss.jni.cc>${tuxguitar.jni.cc}</tuxguitar-oss.jni.cc>
-- <tuxguitar-oss.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-oss.jni.cflags>
-- <tuxguitar-oss.jni.ldflags>-fPIC</tuxguitar-oss.jni.ldflags>
-+ <tuxguitar-oss.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-oss.jni.cflags>
-+ <tuxguitar-oss.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-oss.jni.ldflags>
- <tuxguitar-oss.jni.ldlibs></tuxguitar-oss.jni.ldlibs>
- <tuxguitar-oss.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-oss.jni.ldpath>
- <tuxguitar-oss.jni.library.name>tuxguitar-oss-jni</tuxguitar-oss.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -22,8 +22,8 @@
-
- <tuxguitar-oss.jni.path>${parent.relativePath}/TuxGuitar-oss/jni/</tuxguitar-oss.jni.path>
- <tuxguitar-oss.jni.cc>${tuxguitar.jni.cc}</tuxguitar-oss.jni.cc>
-- <tuxguitar-oss.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-oss.jni.cflags>
-- <tuxguitar-oss.jni.ldflags>-m32 -fPIC</tuxguitar-oss.jni.ldflags>
-+ <tuxguitar-oss.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-oss.jni.cflags>
-+ <tuxguitar-oss.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-oss.jni.ldflags>
- <tuxguitar-oss.jni.ldlibs></tuxguitar-oss.jni.ldlibs>
- <tuxguitar-oss.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-oss.jni.ldpath>
- <tuxguitar-oss.jni.library.name>tuxguitar-oss-jni</tuxguitar-oss.jni.library.name>
-diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml
---- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
-+++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml 2017-02-08 22:06:28.224054080 +0100
-@@ -22,8 +22,8 @@
-
- <tuxguitar-oss.jni.path>${parent.relativePath}/TuxGuitar-oss/jni/</tuxguitar-oss.jni.path>
- <tuxguitar-oss.jni.cc>${tuxguitar.jni.cc}</tuxguitar-oss.jni.cc>
-- <tuxguitar-oss.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-oss.jni.cflags>
-- <tuxguitar-oss.jni.ldflags>-m64 -fPIC</tuxguitar-oss.jni.ldflags>
-+ <tuxguitar-oss.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-oss.jni.cflags>
-+ <tuxguitar-oss.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-oss.jni.ldflags>
- <tuxguitar-oss.jni.ldlibs></tuxguitar-oss.jni.ldlibs>
- <tuxguitar-oss.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-oss.jni.ldpath>
- <tuxguitar-oss.jni.library.name>tuxguitar-oss-jni</tuxguitar-oss.jni.library.name>