summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Guymer2016-11-01 21:51:51 +1000
committerSam Guymer2016-11-01 21:51:51 +1000
commit2908394350f9d294ae5f1d951d30bbe7efec3062 (patch)
tree2c49f6267a8e60eb03e8fcdc6404a7d57c821340
parent88b8ef021936915ac70e8983268895230dc31bab (diff)
downloadaur-2908394350f9d294ae5f1d951d30bbe7efec3062.tar.gz
Support glibc 2.24
Also place files in /usr/lib/jvm instead of /opt
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7681d6f6fe41..0c7b192f9b04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tuxjdk
pkgver = 8.92.03
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tuxjdk/tuxjdk
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aff3a4efba60..7b1162684129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ _jdk_build=14
_tuxjdk_ver=03
pkgver=${_java_ver}.${_jdk_update}.${_tuxjdk_ver}
_repo_ver=jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url='https://github.com/tuxjdk/tuxjdk'
license=('custom')
@@ -54,7 +54,7 @@ case "${CARCH}" in
esac
_jdkname=tuxjdk8
-_jvmdir=/opt/tuxjdk
+_jvmdir=/usr/lib/jvm/java-8-tuxjdk
_prefix="jdk8u-${_repo_ver}/image"
_imgdir="${_prefix}/jvm/openjdk-1.8.0_$(printf '%.2d' ${_jdk_update})"
_tuxjdkdir="tuxjdk-${pkgver}"
@@ -82,6 +82,8 @@ build() {
unset JAVA_HOME
# http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1346
export MAKEFLAGS=${MAKEFLAGS/-j*}
+ # https://hydra.nixos.org/build/41230444/log
+ export CFLAGS="-Wno-error=deprecated-declarations"
# cannot build on gcc 6+
export CC=gcc-5