summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreugene2023-01-08 12:30:43 +0000
committereugene2023-01-08 12:30:43 +0000
commit4bdd2242e0493007f89d5c435fc4894a1fbe0371 (patch)
tree16cb61653412f5772fd954ebd3ca6c4e23f4ec1d
parented699a55c7fffe40f517833d7164740bbd535172 (diff)
downloadaur-4bdd2242e0493007f89d5c435fc4894a1fbe0371.tar.gz
SDL2_Pango v2.1.5 rebuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--freetype2.patch28
3 files changed, 39 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ca8d2815cbd..38f1c45f00db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = tuxpaint
pkgdesc = Drawing program designed for young children
pkgver = 0.9.28
- pkgrel = 1
- url = http://tuxpaint.org/
+ pkgrel = 2
+ url = https://tuxpaint.org/
arch = x86_64
license = GPL
makedepends = gperf
@@ -22,6 +22,8 @@ pkgbase = tuxpaint
optdepends = python2: zh_tw font generator script
backup = etc/tuxpaint/tuxpaint.conf
source = https://downloads.sourceforge.net/sourceforge/tuxpaint/tuxpaint-0.9.28-sdl2.tar.gz
+ source = freetype2.patch
sha256sums = 4f1ed9330feab324070b93630d79ced50ccc4816ab76750119f012b5d904709d
+ sha256sums = SKIP
pkgname = tuxpaint
diff --git a/PKGBUILD b/PKGBUILD
index e674ffad5d21..56efea5f6c4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
# Contributor: Mateusz Herych <heniekk@gmail.com>
# Contributor: Sergio Jovani Guzman <moret.sjg@gmail.com>
# Contributor: royrocks <royrocks13@gmail.com>
@@ -6,10 +6,10 @@
_pkgtype=sdl2
pkgname=tuxpaint
pkgver=0.9.28
-pkgrel=1
+pkgrel=2
pkgdesc='Drawing program designed for young children'
arch=('x86_64')
-url='http://tuxpaint.org/' # no https available
+url='https://tuxpaint.org/'
license=('GPL')
backup=('etc/tuxpaint/tuxpaint.conf')
depends=('fribidi' 'libpaper' 'librsvg' 'libimagequant' 'sdl2_image'
@@ -18,8 +18,8 @@ makedepends=('gperf' 'setconf' 'imagemagick')
optdepends=('tuxpaint-stamps: more stamps'
'tuxpaint-config: configuration manager'
'python2: zh_tw font generator script')
-source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver-$_pkgtype.tar.gz")
-sha256sums=('4f1ed9330feab324070b93630d79ced50ccc4816ab76750119f012b5d904709d')
+source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver-$_pkgtype.tar.gz" "freetype2.patch")
+sha256sums=('4f1ed9330feab324070b93630d79ced50ccc4816ab76750119f012b5d904709d' SKIP)
prepare() {
cd "$pkgname-$pkgver-$_pkgtype"
@@ -40,6 +40,8 @@ prepare() {
# no KDE4-related requirements at installation-time
setconf Makefile ARCH_INSTALL='install-man install-importscript install-bash-completion'
+
+ patch -Np1 < "../freetype2.patch"
}
build() {
diff --git a/freetype2.patch b/freetype2.patch
new file mode 100644
index 000000000000..9a076dac740f
--- /dev/null
+++ b/freetype2.patch
@@ -0,0 +1,28 @@
+--- a/Makefile 2023-01-08 11:38:30.203521345 +0000
++++ b/Makefile 2023-01-08 12:03:51.732619208 +0000
+@@ -292,6 +292,7 @@
+ # SDL Pango is needed to render complex scripts like Thai and Arabic
+ SDL2_PANGO_LIB:=$(call linktest,SDL2_Pango,-lSDL2_Pango,$(SDL_LIBS))
+ NOPANGOFLAG:=$(if $(SDL2_PANGO_LIB),,-DNO_SDLPANGO$(warning -lSDL2_Pango failed, no scripts for you!))
++SDL2_PANGO_CFLAGS:=$(shell $(PKG_CONFIG) SDL2_Pango --cflags)
+
+ SDL_LIBS+=$(SDL_MIXER_LIB) $(SDL2_PANGO_LIB)
+
+@@ -1213,7 +1215,7 @@
+ src/get_fname.h src/debug.h
+ @echo
+ @echo "...Compiling font support..."
+- @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(DEFS) $(ARCH_DEFS) \
++ @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(SDL2_PANGO_CFLAGS) $(DEFS) $(ARCH_DEFS) \
+ -c src/fonts.c -o obj/fonts.o
+
+ obj/dirwalk.o: src/dirwalk.c src/dirwalk.h src/progressbar.h src/fonts.h \
+@@ -1221,7 +1221,7 @@
+ src/debug.h
+ @echo
+ @echo "...Compiling directory-walking support..."
+- @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(DEFS) $(ARCH_DEFS) \
++ @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(SDL2_PANGO_CFLAGS) $(DEFS) $(ARCH_DEFS) \
+ -c src/dirwalk.c -o obj/dirwalk.o
+
+ obj/cursor.o: src/cursor.c src/cursor.h src/debug.h