summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-12-25 22:09:14 +0100
committerhaawda2017-12-25 22:09:14 +0100
commit17f3e435a38ea231fd39a76e7677bc73970102a0 (patch)
treeb18e90173c28a37e61c4705b8bb38a323c0ebd6b
downloadaur-17f3e435a38ea231fd39a76e7677bc73970102a0.tar.gz
initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49573e5acda9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Dec 25 21:09:05 UTC 2017
+pkgbase = tuxpaint-stamps-git
+ pkgdesc = Additional stamps for Tux Paint, cvs version
+ pkgver = 1516.689013db5
+ pkgrel = 1
+ url = http://www.newbreedsoftware.com/tuxpaint/
+ arch = any
+ license = GPL
+ makedepends = cvs
+ provides = tuxpaint-stamps
+ conflicts = tuxpaint-stamps
+ source = git+https://git.code.sf.net/p/tuxpaint/tuxpaint-stamps
+ md5sums = SKIP
+
+pkgname = tuxpaint-stamps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..066e3b9dde38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: royrocks <royrocks13@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=tuxpaint-stamps-git
+pkgver=1516.689013db5
+pkgrel=1
+arch=('any')
+pkgdesc="Additional stamps for Tux Paint, cvs version"
+url="http://www.newbreedsoftware.com/tuxpaint/"
+license=('GPL')
+provides=('tuxpaint-stamps')
+conflicts=('tuxpaint-stamps')
+makedepends=('cvs')
+source=("git+https://git.code.sf.net/p/tuxpaint/tuxpaint-stamps")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${pkgname%-git}"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make DATA_PREFIX=$pkgdir/usr/share/tuxpaint/ install-all
+}