summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Kamil Kozar2016-03-06 00:35:13 +0100
committerDaniel Kamil Kozar2016-03-06 00:35:13 +0100
commit759f99d0085e0473eb3faffef8fe45fabba0fa91 (patch)
tree355e9a7d25c9c41c1d0470fabfe9a9621a7a4750
downloadaur-759f99d0085e0473eb3faffef8fe45fabba0fa91.tar.gz
add a PKGBUILD for the old Tux Racer
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD68
-rw-r--r--invalid-preprocessing-token.diff62
-rw-r--r--tuxracer.desktop14
-rw-r--r--tuxracer.install16
-rw-r--r--tuxracer.xpm292
6 files changed, 487 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14f20527415b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = tuxracer
+ pkgdesc = The Tux racing game - original version
+ pkgver = 0.61
+ pkgrel = 1
+ url = http://tuxracer.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = tcl
+ depends = libx11
+ depends = libxi
+ depends = libxext
+ depends = libxmu
+ depends = libxt
+ depends = mesa
+ depends = glu
+ depends = freeglut
+ depends = sdl
+ depends = sdl_mixer
+ noextract = tuxracer-data-0.61.tar.gz
+ source = http://download.sourceforge.net/tuxracer/tuxracer-0.61.tar.gz
+ source = http://download.sourceforge.net/tuxracer/tuxracer-data-0.61.tar.gz
+ source = invalid-preprocessing-token.diff
+ source = tuxracer.xpm
+ source = tuxracer.desktop
+ source = tuxracer.install
+ sha256sums = a311d09080598fe556134d4b9faed7dc0c2ed956ebb10d062e5d4df022f91eff
+ sha256sums = 3783d204b7bb1ed16aa5e5a1d5944de10fbee05bc7cebb8f616fce84301f3651
+ sha256sums = 6b0ec990d678f2b70f6719d00ec801137f36a842060bfe61409acf20f7cafe73
+ sha256sums = fb4ddee30cabe0c49f9b63a91abde762847b0a994fc6ae82ad84eb88a5f9f155
+ sha256sums = bf1ac9b1cb6eb2642ab10dcb42f3f73eab4a7e675e7fee1f176f6a462da5ed40
+ sha256sums = 51c656197322833ee3140d71452d31e3258e4bdbeabadc6588562150077281e4
+
+pkgname = tuxracer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8883f9ec2e47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Daniel Kamil Kozar <dkk089@gmail.com>
+pkgname=tuxracer
+pkgver=0.61
+pkgrel=1
+pkgdesc="The Tux racing game - original version"
+arch=('i686' 'x86_64')
+url="http://tuxracer.sourceforge.net/"
+license=('GPL2')
+depends=('tcl' 'libx11' 'libxi' 'libxext' 'libxmu' 'libxt' 'mesa' 'glu'
+ 'freeglut' 'sdl' 'sdl_mixer')
+source=(
+ "http://download.sourceforge.net/tuxracer/${pkgname}-${pkgver}.tar.gz"
+ "http://download.sourceforge.net/tuxracer/${pkgname}-data-${pkgver}.tar.gz"
+ 'invalid-preprocessing-token.diff'
+ 'tuxracer.xpm'
+ 'tuxracer.desktop'
+ 'tuxracer.install'
+)
+noextract=("${pkgname}-data-${pkgver}.tar.gz")
+sha256sums=(
+ 'a311d09080598fe556134d4b9faed7dc0c2ed956ebb10d062e5d4df022f91eff'
+ '3783d204b7bb1ed16aa5e5a1d5944de10fbee05bc7cebb8f616fce84301f3651'
+ '6b0ec990d678f2b70f6719d00ec801137f36a842060bfe61409acf20f7cafe73'
+ 'fb4ddee30cabe0c49f9b63a91abde762847b0a994fc6ae82ad84eb88a5f9f155'
+ 'bf1ac9b1cb6eb2642ab10dcb42f3f73eab4a7e675e7fee1f176f6a462da5ed40'
+ '51c656197322833ee3140d71452d31e3258e4bdbeabadc6588562150077281e4'
+)
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/invalid-preprocessing-token.diff"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # CPPFLAGS contains -D_FORTIFY_SOURCE=2 by default. when configure checks how
+ # to invoke the preprocessor, it rightly uses the value of $CPPFLAGS, but it
+ # causes an error when processing the headers, saying that "_FORTIFY_SOURCE
+ # requires compiling with optimization". this causes the script to revert to
+ # the default location of /lib/cpp for the preprocessor, which causes the rest
+ # of the configuration to fail, as it does not exist. therefore, append
+ # CPPFLAGS to CFLAGS and CXXFLAGS before passing them to configure and leave
+ # CPPFLAGS empty. this is not foolproof and bound to break, but works so far.
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="" \
+ ./configure --prefix=/usr --with-data-dir=/usr/share/tuxracer
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ mkdir -p "$pkgdir/usr/share"
+ pushd "$pkgdir/usr/share"
+ tar xf "$srcdir/${pkgname}-data-${pkgver}.tar.gz"
+ mv "${pkgname}-data-${pkgver}" tuxracer
+ popd
+
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ cp "$srcdir/tuxracer.xpm" "$pkgdir/usr/share/pixmaps"
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$srcdir/tuxracer.desktop" "$pkgdir/usr/share/applications"
+}
diff --git a/invalid-preprocessing-token.diff b/invalid-preprocessing-token.diff
new file mode 100644
index 000000000000..a25bf2c9471f
--- /dev/null
+++ b/invalid-preprocessing-token.diff
@@ -0,0 +1,62 @@
+diff -Naur tuxracer-0.61/src/game_config.c tuxracer-0.61-my/src/game_config.c
+--- tuxracer-0.61/src/game_config.c 2001-01-30 21:04:43.000000000 +0100
++++ tuxracer-0.61-my/src/game_config.c 2016-03-05 17:57:46.968434091 +0100
+@@ -114,26 +114,26 @@
+ */
+
+ #define INIT_PARAM( nam, val, typename, commnt ) \
+- Params. ## nam ## .loaded = False; \
+- Params. ## nam ## .name = #nam; \
+- Params. ## nam ## .deflt. ## typename ## _val = val; \
+- Params. ## nam ## .comment = commnt;
++ Params.nam.loaded = False; \
++ Params.nam.name = #nam; \
++ Params.nam.deflt.typename ## _val = val; \
++ Params.nam.comment = commnt;
+
+ #define INIT_PARAM_STRING( nam, val, commnt ) \
+ INIT_PARAM( nam, val, string, commnt ); \
+- Params. ## nam ## .type = PARAM_STRING;
++ Params.nam.type = PARAM_STRING;
+
+ #define INIT_PARAM_CHAR( nam, val, commnt ) \
+ INIT_PARAM( nam, val, char, commnt ); \
+- Params. ## nam ## .type = PARAM_CHAR;
++ Params.nam.type = PARAM_CHAR;
+
+ #define INIT_PARAM_INT( nam, val, commnt ) \
+ INIT_PARAM( nam, val, int, commnt ); \
+- Params. ## nam ## .type = PARAM_INT;
++ Params.nam.type = PARAM_INT;
+
+ #define INIT_PARAM_BOOL( nam, val, commnt ) \
+ INIT_PARAM( nam, val, bool, commnt ); \
+- Params. ## nam ## .type = PARAM_BOOL;
++ Params.nam.type = PARAM_BOOL;
+
+
+ /*
+@@ -304,19 +304,18 @@
+ p->loaded = True;
+ }
+
+-
+ /*
+ * Creates set/get functions for each parameter
+ */
+ #define FN_PARAM( name, typename, type ) \
+ type getparam_ ## name() { \
+- if ( !Params. ## name ## .loaded ) { \
+- fetch_param_ ## typename( &( Params. ## name ) ); \
++ if ( !Params.name.loaded ) { \
++ fetch_param_ ## typename( &( Params.name ) ); \
+ } \
+- return Params. ## name ## .val. ## typename ## _val; \
++ return Params.name.val.typename ## _val; \
+ } \
+ void setparam_ ## name( type val) { \
+- set_param_ ## typename( &( Params. ## name ), val ); }
++ set_param_ ## typename( &( Params.name ), val ); }
+
+ #define FN_PARAM_STRING( name ) \
+ FN_PARAM( name, string, char* )
diff --git a/tuxracer.desktop b/tuxracer.desktop
new file mode 100644
index 000000000000..0f96514d671f
--- /dev/null
+++ b/tuxracer.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=0.61
+Type=Application
+Name=Tux Racer
+GenericName=Arcade Game
+Comment=Original penguin racing game
+Icon=tuxracer
+
+Exec=tuxracer
+Terminal=false
+StartupNotify=false
+
+Categories=Game;ArcadeGame;
+Keywords=game;tux;3D;penguin;race;arcade;
diff --git a/tuxracer.install b/tuxracer.install
new file mode 100644
index 000000000000..930d9be7832d
--- /dev/null
+++ b/tuxracer.install
@@ -0,0 +1,16 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/pixmaps
+}
+
+pre_upgrade() {
+ post_install $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/tuxracer.xpm b/tuxracer.xpm
new file mode 100644
index 000000000000..2527efb192f9
--- /dev/null
+++ b/tuxracer.xpm
@@ -0,0 +1,292 @@
+/* XPM */
+static char * tuxracer_icon_xpm[] = {
+"32 32 257 2",
+" c None",
+". c #7AA1E5",
+"+ c #CDDDFF",
+"@ c #FFFFFF",
+"# c #BCDDFF",
+"$ c #99BBEE",
+"% c #FDFDFF",
+"& c #CADCFF",
+"* c #ECFDFE",
+"= c #98A9BA",
+"- c #112222",
+"; c #111111",
+"> c #BBBBCC",
+", c #FEFEFE",
+"' c #CCDDFF",
+") c #ECECFF",
+"! c #DDEEFF",
+"~ c #344556",
+"{ c #010102",
+"] c #001111",
+"^ c #657665",
+"/ c #656565",
+"( c #000000",
+"_ c #131302",
+": c #AABBCC",
+"< c #9ABBEE",
+"[ c #FEFFFF",
+"} c #666778",
+"| c #223322",
+"1 c #223333",
+"2 c #000100",
+"3 c #EEEEFF",
+"4 c #BACCFF",
+"5 c #AABBEE",
+"6 c #DCDCED",
+"7 c #122324",
+"8 c #224333",
+"9 c #112211",
+"0 c #222222",
+"a c #546554",
+"b c #BCCCCD",
+"c c #ABBBEE",
+"d c #CBDCED",
+"e c #011212",
+"f c #225544",
+"g c #121200",
+"h c #445554",
+"i c #446655",
+"j c #556655",
+"k c #678989",
+"l c #ECEDFF",
+"m c #011223",
+"n c #011211",
+"o c #656611",
+"p c #BA9811",
+"q c #776611",
+"r c #222212",
+"s c #334444",
+"t c #001100",
+"u c #232312",
+"v c #997711",
+"w c #DDBA11",
+"x c #FFCC22",
+"y c #DCBA11",
+"z c #886611",
+"A c #78899A",
+"B c #897700",
+"C c #CCAA11",
+"D c #EEBB22",
+"E c #DDAA11",
+"F c #998800",
+"G c #454500",
+"H c #BCCDFF",
+"I c #121212",
+"J c #443311",
+"K c #555500",
+"L c #554400",
+"M c #666623",
+"N c #342323",
+"O c #788989",
+"P c #EEFFFF",
+"Q c #B9CCFF",
+"R c #BACBDC",
+"S c #343423",
+"T c #446644",
+"U c #446633",
+"V c #556622",
+"W c #667754",
+"X c #A998A9",
+"Y c #777777",
+"Z c #565667",
+"` c #FDFFFF",
+" . c #CCDDEE",
+".. c #788888",
+"+. c #AAAAAA",
+"@. c #789978",
+"#. c #789988",
+"$. c #ABBBBB",
+"%. c #DDDDDD",
+"&. c #666666",
+"*. c #010101",
+"=. c #000101",
+"-. c #98A9B9",
+";. c #BBCCDD",
+">. c #676767",
+",. c #BBBBBB",
+"'. c #CCCCCC",
+"). c #DCDDDC",
+"!. c #EEEEEE",
+"~. c #DBDBDB",
+"{. c #232323",
+"]. c #ABABBC",
+"^. c #235544",
+"/. c #778877",
+"(. c #999999",
+"_. c #566767",
+":. c #000001",
+"<. c #657698",
+"[. c #BBDDFF",
+"}. c #EDEDFE",
+"|. c #132424",
+"1. c #A9A9A9",
+"2. c #DCDCDC",
+"3. c #111122",
+"4. c #ABBCCD",
+"5. c #FDFEFF",
+"6. c #DDDDFF",
+"7. c #DCEDFD",
+"8. c #122323",
+"9. c #224433",
+"0. c #110000",
+"a. c #344534",
+"b. c #9ABCEE",
+"c. c #84A8EC",
+"d. c #CADDFF",
+"e. c #233423",
+"f. c #998899",
+"g. c #557787",
+"h. c #223323",
+"i. c #667766",
+"j. c #888888",
+"k. c #A9BACA",
+"l. c #EDEDFF",
+"m. c #CCCCDD",
+"n. c #DDDDCC",
+"o. c #767787",
+"p. c #122312",
+"q. c #447744",
+"r. c #334455",
+"s. c #BBCCFF",
+"t. c #AA9977",
+"u. c #AA9933",
+"v. c #CC9922",
+"w. c #EECC22",
+"x. c #EECC44",
+"y. c #665511",
+"z. c #335533",
+"A. c #557755",
+"B. c #777766",
+"C. c #AABBBB",
+"D. c #556644",
+"E. c #232300",
+"F. c #121100",
+"G. c #010100",
+"H. c #223354",
+"I. c #CCDDDC",
+"J. c #897802",
+"K. c #BB8811",
+"L. c #DDBB11",
+"M. c #CBA911",
+"N. c #232200",
+"O. c #113333",
+"P. c #335544",
+"Q. c #557744",
+"R. c #887788",
+"S. c #9999AA",
+"T. c #998822",
+"U. c #BAA922",
+"V. c #443300",
+"W. c #222200",
+"X. c #444454",
+"Y. c #BACBDB",
+"Z. c #666601",
+"`. c #997700",
+" + c #BA8811",
+".+ c #EEBB11",
+"++ c #897800",
+"@+ c #443422",
+"#+ c #345533",
+"$+ c #336633",
+"%+ c #778888",
+"&+ c #777787",
+"*+ c #997733",
+"=+ c #CC9900",
+"-+ c #FFDD22",
+";+ c #CCAA22",
+">+ c #343401",
+",+ c #666600",
+"'+ c #887700",
+")+ c #777711",
+"!+ c #776633",
+"~+ c #AA7701",
+"{+ c #CC9911",
+"]+ c #343513",
+"^+ c #333300",
+"/+ c #A98811",
+"(+ c #BB9901",
+"_+ c #787711",
+":+ c #456645",
+"<+ c #445533",
+"[+ c #886600",
+"}+ c #BB9911",
+"|+ c #CCDDDD",
+"1+ c #334411",
+"2+ c #454400",
+"3+ c #776600",
+"4+ c #9A7700",
+"5+ c #999998",
+"6+ c #CBCBED",
+"7+ c #88AAAA",
+"8+ c #557777",
+"9+ c #556611",
+"0+ c #AA7700",
+"a+ c #AA7711",
+"b+ c #AA8811",
+"c+ c #AB9A78",
+"d+ c #DDEEEE",
+"e+ c #898989",
+"f+ c #443412",
+"g+ c #444501",
+"h+ c #AB8935",
+"i+ c #EEEEFE",
+"j+ c #ABBCCC",
+"k+ c #556665",
+"l+ c #786713",
+"m+ c #CBCBDB",
+"n+ c #667744",
+"o+ c #667733",
+"p+ c #FFFFFE",
+"q+ c #777765",
+"r+ c #444401",
+"s+ c #444400",
+"t+ c #445500",
+"u+ c #787878",
+"v+ c #DDDDEE",
+"w+ c #99AAAA",
+"x+ c #454502",
+"y+ c #454512",
+"z+ c #564535",
+"A+ c #555511",
+"B+ c #556643",
+"C+ c #BABACB",
+"D+ c #EDFEFE",
+"E+ c #80A5E9",
+"F+ c #97B9ED",
+"G+ c #DBECFF",
+"H+ c #AACCEE",
+". . . . . . . . . . . . . . + @ @ @ @ @ @ # . . . . . . . . . . ",
+". . . . . . . . . . . . $ % @ @ @ @ @ @ @ @ & . . . . . . . . . ",
+". . . . . . . . . . . $ @ @ * = - ; ; - > , @ ' . . . . . . . . ",
+". . . . . . . . . . . ) @ ! ~ { ] ^ / ( _ : @ @ $ . . . . . . . ",
+". . . . . . . . . . < [ , } ( ( ( | 1 2 ( - 3 @ 4 . . . . . . . ",
+". . . . . . . . . . 5 [ 6 7 8 9 ( 0 a 0 ( ( b @ ) . . . . . . . ",
+". . . . . . . . . . c @ d e f 1 g h i j ( ( k , l . . . . . . . ",
+". . . . . . . . . . c @ 6 m n o p q r s t ( k , l . . . . . . . ",
+". . . . . . . . . . < [ 6 u v w x x y z t ( A , l . . . . . . . ",
+". . . . . . . . . . < [ 6 u B C D E F G ( ( A , l . . . . . . . ",
+". . . . . . . . . . H @ 6 I J K K L M N ( ( O , P . . . . . . . ",
+". . . . . . . . . Q @ @ R S T U V W X Y ( ( Z , ` ' . . . . . . ",
+". . . . . . . . H @ , ...+.@.#.$.%.%.%.&.*.=.-.@ @ ! . . . . . ",
+". . . . . . . Q @ @ ;.>.,.'.'.).!.!.@ @ ~.{.=.; ].@ ` ! . . . . ",
+". . . . . . < [ , > ^./.(.+.,.,.'.'.'.'.'._.( ( :.<.@ @ [.. . . ",
+". . . . . . < [ }.|.j 1.,.'.'.'.%.%.'.'.2.+.; ( ; 3.4.@ 5.$ . . ",
+". . . . . . 6.@ 7.8.Y +.,.'.'.'.%.%.%.%.!.%.9.( ( 0.a.}.@ b.. . ",
+". . . c.4 d.3 @ = e.Y f.+.,.'.,.%.%.%.%.%.%.a ( ( ( 8.}.@ ' . . ",
+". $ 3 @ @ @ @ @ g.h.i.j.(.+.,.,.'.'.'.'.'.'./ *.( ( *.k.@ @ . . ",
+"$ l.@ @ P m.n.P o.p.q.i.j.(.+.+.,.,.,.,.,.'./ *.( ( *.r.@ @ . . ",
+"s.@ }.t.u.v.w.x.y.n z.A.B.j.j.(.+.+.+.+.,.C.D.E.F.G.( H.@ @ . . ",
+"s.@ I.J.K.C L.x M.N.O.P.Q.Y R.j.j.(.(.(.S.j.T.y U.V.W.X.@ @ $ . ",
+"@ @ Y.Z.`. +C .+.+++@+#+$+q.i././././.%+&+*+=+D -+w.E ;+!.@ 4 . ",
+"@ @ i >+,+'+K.C .+E +)+$+$+T A.A.A.A.i.!+~+{+C L.L.L.E %.@ 4 . ",
+"@ @ ;.]+^+K '+/+C L.(+_+:+:+T $+T T q.<+[+K.}+{+{+{+{+}+|+@ l . ",
+"H @ , m.1+^+2+3+4+{+(+5+6+7+8+A.q.i T 9+`.0+0+a+b+K.b+a+c+@ % . ",
+". Q @ @ d+e+f+g+K '+h+i+@ @ @ .j+;.k+Z.,+,+3+'+'+'+'+3+l+, 5.. ",
+". . H @ @ @ m+n+K o+!.p+@ @ @ @ @ @ q+r+s+s+K t+K K t+s+u+, 5.. ",
+". . . $ ! ` @ P v+3 @ @ $ . 4 d.3 @ w+x+s+s+s+^+>+y+z+S.3 @ ) . ",
+". . . . . s.@ @ @ @ @ b.. . . . 6.@ , S.y.,+A+B+C+6 D+, @ 3 c.. ",
+". . . . . . E+5 5 5 F+. . . . . . G+@ @ @ @ @ @ @ @ [ [ G+c.. . ",
+". . . . . . . . . . . . . . . . . . ! @ @ @ @ @ @ ' H+E+. . . . "};