summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-06-09 13:18:03 +0200
committerValHue2015-06-09 13:18:03 +0200
commit23a9559dce4c7f2a3a711e6a35d439d51c130d7a (patch)
tree2593b2d17099ca71547d45c0888039a0171f4947
downloadaur-23a9559dce4c7f2a3a711e6a35d439d51c130d7a.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
3 files changed, 88 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..476fb7d29918
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = tvenlinux-desktop
+ pkgdesc = Simple bash script to watch and record TV on GNU/Linux/BSD without capture card/tuner. (TV in Spain, Peru, Chile, Cuba, Venezuela, Bolivia and Argentina)
+ pkgver = 20140601
+ pkgrel = 1
+ url = http://www.tvenlinux.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = mplayer
+ depends = rtmpdump
+ optdepends = zenity: for GTK users
+ optdepends = kdialog: for QT users
+ optdepends = curl: for view EPG (Electronic Program Guide)
+ source = http://www.tvenlinux.com/TVenLinux.sh
+ source = http://www.tvenlinux.com/busi_tv.png
+
+pkgname = tvenlinux-desktop
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc0a9add2a1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tvenlinux-desktop
+ pkgdesc = Simple bash script to watch and record TV on GNU/Linux/BSD without capture card/tuner. (TV in Spain, Peru, Chile, Cuba, Venezuela, Bolivia and Argentina)
+ pkgver = 20140601
+ pkgrel = 1
+ url = http://www.tvenlinux.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = mplayer
+ depends = rtmpdump
+ optdepends = zenity: for GTK users
+ optdepends = kdialog: for QT users
+ optdepends = curl: for view EPG (Electronic Program Guide)
+ source = http://www.tvenlinux.com/TVenLinux.sh
+ source = http://www.tvenlinux.com/busi_tv.png
+ md5sums = a8f1c8d9d87f84e29bcca2de1656a3fd
+ md5sums = 57fe139851d8227320dc2b78a9390dd6
+
+pkgname = tvenlinux-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e94574dd1456
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+
+pkgname=tvenlinux-desktop
+pkgver=20140601
+pkgrel=1
+pkgdesc="Simple bash script to watch and record TV on GNU/Linux/BSD without capture card/tuner. (TV in Spain, Peru, Chile, Cuba, Venezuela, Bolivia and Argentina)"
+url="http://www.tvenlinux.com/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('mplayer' 'rtmpdump')
+optdepends=('zenity: for GTK users' 'kdialog: for QT users' 'curl: for view EPG (Electronic Program Guide)')
+source=("http://www.tvenlinux.com/TVenLinux.sh" "http://www.tvenlinux.com/busi_tv.png")
+md5sums=('a8f1c8d9d87f84e29bcca2de1656a3fd'
+ '57fe139851d8227320dc2b78a9390dd6')
+
+_pkgname="TVenLinux"
+
+_pkgname_desktop="#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=TVenLinux
+Exec=TVenLinux
+Icon=TVenLinux
+Type=Application
+Comment=Script to view more than 160 channels in Spanish TDT.
+Comment[es]=Script para ver más de 160 canales de TDT en Español.
+Terminal=false
+Categories=GNOME;AudioVideo;P2P;Video;TV;GTK;
+MimeType=x-scheme-handler/sop;"
+
+pkgver() {
+ cd "${srcdir}"
+ cat TVenLinux.sh | grep -e 'V_script=' | sed -e 's/V_script=//;s/"//g;s/;//;s/\///g;s/^\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)/\5\6\7\8\3\4\1\2/'
+}
+
+build() {
+ cd "${srcdir}"
+ mv busi_tv.png ${_pkgname}.png
+ echo -e "${_pkgname_desktop}" | tee ${_pkgname}.desktop
+}
+
+package() {
+ cd "${srcdir}"
+ install -d ${pkgdir}/usr/share/applications
+ install -d ${pkgdir}/usr/share/pixmaps
+ install -d ${pkgdir}/usr/bin
+ install -m 755 ${_pkgname}.sh ${pkgdir}/usr/bin/${_pkgname}
+ install -m 644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications
+ install -m 644 ${_pkgname}.png ${pkgdir}/usr/share/pixmaps
+}