summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2018-09-22 22:39:22 -0400
committerDan Ziemba2018-09-22 22:39:22 -0400
commitc9dd687b558fcd233d2360506b04c4cb96c9bd22 (patch)
treebea171d7b6169c2b8d9ccb92efb26e33ee2ae159
parent01b8bd8572dadf03a4fae08480beb1796708fa65 (diff)
downloadaur-c9dd687b558fcd233d2360506b04c4cb96c9bd22.tar.gz
Ignore missing libavresample
Arch's version of ffmpeg no longer provides this, but libswresample should take its place.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--ignore-missing-libavresample.patch24
3 files changed, 33 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f7d60c16d59..a8d8324a241c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tvheadend-git
pkgdesc = TV streaming server for Linux
- pkgver = 4.3.r1292.g9b9ee6859
+ pkgver = 4.3.r1361.ge1c03470d
pkgrel = 1
url = https://tvheadend.org/
install = tvheadend.install
@@ -30,8 +30,10 @@ pkgbase = tvheadend-git
backup = etc/conf.d/tvheadend
source = tvheadend-git::git+https://github.com/tvheadend/tvheadend.git#branch=master
source = dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend
+ source = ignore-missing-libavresample.patch
md5sums = SKIP
md5sums = SKIP
+ md5sums = 65ff2ee6a7861f295f21d4a2a5aa5ce0
pkgname = tvheadend-git
diff --git a/PKGBUILD b/PKGBUILD
index 92b6122bd749..e813932fc334 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
-pkgver=4.3.r1292.g9b9ee6859
+pkgver=4.3.r1361.ge1c03470d
pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -34,10 +34,12 @@ backup=('etc/conf.d/tvheadend')
source=(
"${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
'dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend'
+ 'ignore-missing-libavresample.patch'
)
md5sums=(
'SKIP'
'SKIP'
+ '65ff2ee6a7861f295f21d4a2a5aa5ce0'
)
pkgver() {
@@ -52,6 +54,9 @@ prepare() {
cp -a "dvb-scan-tables" "${_dvbscan}"
rm -rf "${_dvbscan}/.git"
touch "${_dvbscan}/.stamp"
+
+ cd "${_gitname}"
+ patch -p1 -i ../ignore-missing-libavresample.patch
}
build() {
diff --git a/ignore-missing-libavresample.patch b/ignore-missing-libavresample.patch
new file mode 100644
index 000000000000..5a919fa9497a
--- /dev/null
+++ b/ignore-missing-libavresample.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index 1253be14a..fbf0987ee 100644
+--- a/Makefile
++++ b/Makefile
+@@ -88,7 +88,6 @@ ifeq ($(CONFIG_LIBAV),yes)
+ FFMPEG_LIBS := \
+ libavfilter \
+ libswresample \
+- libavresample \
+ libswscale \
+ libavformat \
+ libavcodec \
+diff --git a/configure b/configure
+index 9f34ac36f..b62bac3e9 100755
+--- a/configure
++++ b/configure
+@@ -599,7 +599,6 @@ else
+
+ check_pkg libavfilter ">=6.47.100" || has_libav=false
+ check_pkg libswresample ">=2.1.100" || has_libav=false
+- check_pkg libavresample ">=3.0.0" || has_libav=false
+ check_pkg libswscale ">=4.1.100" || has_libav=false
+ check_pkg libavformat ">=57.41.100" || has_libav=false
+ check_pkg libavcodec ">=57.48.101" || has_libav=false