summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrancoism902021-03-21 15:07:33 +0100
committerfrancoism902021-03-21 15:07:33 +0100
commitec586892600df55e51fb2cc1ba72b63d73ca427d (patch)
tree7e7cb164ad8771bb5bfef639a26766f3b9ce33d6
parent93db26656edc3294ade3be9c23bc0517bc87d788 (diff)
downloadaur-ec586892600df55e51fb2cc1ba72b63d73ca427d.tar.gz
Merge breaking changes
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD148
-rw-r--r--ignore-missing-libavresample.patch12
-rw-r--r--tmpfile.conf4
-rw-r--r--tvheadend.install24
-rw-r--r--tvheadend.service16
-rw-r--r--user.conf2
7 files changed, 107 insertions, 131 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3c09d929ba8..c59910528d80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = tvheadend-git
pkgdesc = TV streaming server for Linux
- pkgver = 4.3.r1878.ge59b92e9f
+ pkgver = 4.3.r1947.gdbaa0f850
pkgrel = 1
url = https://tvheadend.org/
- install = tvheadend.install
arch = i686
arch = x86_64
arch = arm
@@ -15,25 +14,34 @@ pkgbase = tvheadend-git
makedepends = python
depends = avahi
depends = ffmpeg
+ depends = libavresample
depends = libdvbcsa
depends = libfdk-aac
depends = libhdhomerun
+ depends = libogg
+ depends = libtheora
+ depends = libvorbis
+ depends = libvpx
depends = openssl
+ depends = opus
depends = pcre2
+ depends = pngquant
depends = uriparser
+ depends = x264
+ depends = x265
optdepends = xmltv: For an alternative source of programme listings
provides = tvheadend
conflicts = tvheadend
- conflicts = hts-tvheadend
- conflicts = hts-tvheadend-svn
- conflicts = tvheadend-git
- backup = etc/conf.d/tvheadend
- source = tvheadend-git::git+https://github.com/tvheadend/tvheadend.git#branch=master
- source = dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend
- source = ignore-missing-libavresample.patch
- md5sums = SKIP
- md5sums = SKIP
- md5sums = ab3e00343f57b70b5e02a981e0a16055
+ options = !strip
+ options = emptydirs
+ source = tvheadend-git::git+https://github.com/tvheadend/tvheadend.git
+ source = tvheadend.service
+ source = tmpfile.conf
+ source = user.conf
+ sha512sums = SKIP
+ sha512sums = d29662ee47f2d0da98d444819f730a8c487999454d60d7397b0f67068300ab5111ffce18befc9fdef5ff8fa1925213716837ea44808fb934197e4a56f98de8a7
+ sha512sums = 1080c8a2530d1f16ab5304cdd81c9c9da23b281e44a4874f4921905c843d876831214af481f9be91a74291ed4a6a10684dbdfb8f926b51bbb6895b92d493b201
+ sha512sums = 5e0475cfe1f915bd3269ba3e9e0ca6cc7e492988bfd4f1feafcbbd3e8b0276c228f0b08a4116f3213d12c0ea940eff0dc71601a6e6ddcda934964cf51a665539
pkgname = tvheadend-git
diff --git a/PKGBUILD b/PKGBUILD
index 309d2477158e..66b3c8c683fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,113 +1,95 @@
-# Maintainer: Dan Ziemba <zman0900@gmail.com>
+# Maintainer: Francois Menning <f.menning@pm.me>
+# Contributor: Dan Ziemba <zman0900@gmail.com>
# Contributor: Benjamin Hedrich <kiwisauce (a) pagenotfound (dot) de>
-pkgname=tvheadend-git
_gitname='tvheadend-git'
-pkgver=4.3.r1878.ge59b92e9f
+pkgname=tvheadend-git
+pkgver=4.3.r1947.gdbaa0f850
pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/"
license=('GPL3')
depends=(
- 'avahi'
- 'ffmpeg'
- 'libdvbcsa'
- 'libfdk-aac'
- 'libhdhomerun'
- 'openssl'
- 'pcre2'
- 'uriparser'
+ 'avahi'
+ 'ffmpeg'
+ 'libavresample'
+ 'libdvbcsa'
+ 'libfdk-aac'
+ 'libhdhomerun'
+ 'libogg'
+ 'libtheora'
+ 'libvorbis'
+ 'libvpx'
+ 'openssl'
+ 'opus'
+ 'pcre2'
+ 'pngquant'
+ 'uriparser'
+ 'x264'
+ 'x265'
)
makedepends=(
- 'git'
- 'python'
+ 'git'
+ 'python'
)
optdepends=(
- 'xmltv: For an alternative source of programme listings'
+ 'xmltv: For an alternative source of programme listings'
)
+options=('!strip' 'emptydirs')
provides=('tvheadend')
-conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'tvheadend-git')
-install=tvheadend.install
-backup=('etc/conf.d/tvheadend')
-
+conflicts=('tvheadend')
source=(
- "${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
- 'dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend'
- 'ignore-missing-libavresample.patch'
-)
-md5sums=(
- 'SKIP'
- 'SKIP'
- 'ab3e00343f57b70b5e02a981e0a16055'
+ "${_gitname}::git+https://github.com/tvheadend/tvheadend.git"
+ tvheadend.service
+ tmpfile.conf
+ user.conf
)
+sha512sums=('SKIP'
+ 'd29662ee47f2d0da98d444819f730a8c487999454d60d7397b0f67068300ab5111ffce18befc9fdef5ff8fa1925213716837ea44808fb934197e4a56f98de8a7'
+ '1080c8a2530d1f16ab5304cdd81c9c9da23b281e44a4874f4921905c843d876831214af481f9be91a74291ed4a6a10684dbdfb8f926b51bbb6895b92d493b201'
+ '5e0475cfe1f915bd3269ba3e9e0ca6cc7e492988bfd4f1feafcbbd3e8b0276c228f0b08a4116f3213d12c0ea940eff0dc71601a6e6ddcda934964cf51a665539')
pkgver() {
- cd "${srcdir}/${_gitname}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "${srcdir}"
- _dvbscan="${_gitname}/data/dvb-scan"
- rm -rf "${_dvbscan}"
- cp -a "dvb-scan-tables" "${_dvbscan}"
- rm -rf "${_dvbscan}/.git"
- touch "${_dvbscan}/.stamp"
-
- cd "${_gitname}"
- patch -p1 -i ../ignore-missing-libavresample.patch
+ cd "${srcdir}/${_gitname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_gitname}"
+
+ # Work-around for GCC 10
+ export CFLAGS="${CFLAGS} -fcommon"
- # Work-around for GCC 10
- export CFLAGS="${CFLAGS} -fcommon"
+ ./configure \
+ --prefix=/usr \
+ --datadir=/var/lib \
+ --mandir=/usr/share/man/man1 \
+ --python=python3 \
+ --enable-avahi \
+ --enable-zlib \
+ --enable-pngquant \
+ --enable-libav \
+ --disable-ffmpeg_static --enable-ffmpeg \
+ --disable-libx264_static --enable-libx264 \
+ --disable-libx265_static --enable-libx265 \
+ --disable-libvpx_static --enable-libvpx \
+ --disable-libogg_static --enable-libogg \
+ --disable-libtheora_static --enable-libtheora \
+ --disable-libvorbis_static --enable-libvorbis \
+ --disable-libfdkaac_static --enable-libfdkaac \
+ --disable-libopus_static --enable-libopus \
+ --disable-hdhomerun_static --enable-hdhomerun_client
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man/man1 \
- --release \
- --python=python3 \
- --enable-avahi \
- --enable-zlib \
- --disable-ffmpeg_static --enable-libav \
- --disable-libx264_static --enable-libx264 \
- --disable-libx265_static --enable-libx265 \
- --disable-libvpx_static --enable-libvpx \
- --disable-libtheora_static --enable-libtheora \
- --disable-libvorbis_static --enable-libvorbis \
- --disable-libfdkaac_static --enable-libfdkaac \
- --disable-libopus_static --enable-libopus \
- --disable-nvenc \
- --enable-vaapi \
- --enable-inotify \
- --enable-epoll \
- --disable-pcre --enable-pcre2 \
- --enable-uriparser \
- --enable-dvben50221 \
- --enable-dbus_1 \
- --disable-hdhomerun_static --enable-hdhomerun_client \
- --enable-tvhcsa
- make
+ make
}
package() {
- cd "${srcdir}/${_gitname}"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${_gitname}"
- install -D -m 644 "${srcdir}/${_gitname}/rpm/tvheadend.service" \
- "$pkgdir/usr/lib/systemd/system/tvheadend.service"
- sed -i 's|/etc/sysconfig|/etc/conf.d|g' \
- "$pkgdir/usr/lib/systemd/system/tvheadend.service"
+ make DESTDIR="$pkgdir/" install
- install -d "$pkgdir/etc/conf.d"
- cat << EOF > "$pkgdir/etc/conf.d/tvheadend"
-# Configuration file for the tvheadend service.
-
-MALLOC_ARENA_MAX=4
-OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 9982"
-EOF
+ install -Dm 644 "${srcdir}/tvheadend.service" -t "${pkgdir}/usr/lib/systemd/system"
+ install -Dm 644 "${srcdir}/user.conf" "${pkgdir}/usr/lib/sysusers.d/tvheadend.conf"
+ install -Dm 644 "${srcdir}/tmpfile.conf" "${pkgdir}/usr/lib/tmpfiles.d/tvheadend.conf"
}
-
diff --git a/ignore-missing-libavresample.patch b/ignore-missing-libavresample.patch
deleted file mode 100644
index 31ff86c7ba54..000000000000
--- a/ignore-missing-libavresample.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 1253be14a..fbf0987ee 100644
---- a/Makefile
-+++ b/Makefile
-@@ -88,7 +88,6 @@ ifeq ($(CONFIG_LIBAV),yes)
- FFMPEG_LIBS := \
- libavfilter \
- libswresample \
-- libavresample \
- libswscale \
- libavformat \
- libavcodec \
diff --git a/tmpfile.conf b/tmpfile.conf
new file mode 100644
index 000000000000..447f2fe94fa0
--- /dev/null
+++ b/tmpfile.conf
@@ -0,0 +1,4 @@
+d /etc/tvheadend 0750 tvheadend tvheadend -
+d /var/lib/tvheadend 0755 tvheadend tvheadend -
+Z /var/lib/tvheadend/data - tvheadend tvheadend -
+Z /var/lib/tvheadend/src - tvheadend tvheadend - \ No newline at end of file
diff --git a/tvheadend.install b/tvheadend.install
deleted file mode 100644
index f2446007e519..000000000000
--- a/tvheadend.install
+++ /dev/null
@@ -1,24 +0,0 @@
-HTS_USER=hts
-HTS_UID=1337
-HTS_GROUP=video
-
-post_install() {
- if ! getent passwd $HTS_USER &> /dev/null; then
- useradd -u $HTS_UID -g $HTS_GROUP -m -s /bin/false $HTS_USER &> /dev/null
- passwd -l $HTS_USER &> /dev/null
- echo " ==> User '$HTS_USER' created"
- fi
-
-cat << 'EOM'
- ==> All configuration is maintained through the web interface:
- ==>
- ==> http://localhost:9981/
- ==>
- ==> Default login without username/password.
-EOM
-}
-
-post_remove() {
- userdel $HTS_USER &> /dev/null
- echo " ==> User '$HTS_USER' removed"
-}
diff --git a/tvheadend.service b/tvheadend.service
new file mode 100644
index 000000000000..2c47f2172418
--- /dev/null
+++ b/tvheadend.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Tvheadend - a TV streaming server and DVR
+Wants=network.target
+
+[Service]
+Type=forking
+RuntimeDirectory=tvheadend
+PrivateTmp=yes
+Environment=PID_DIR=/run/tvheadend
+User=tvheadend
+Group=tvheadend
+ExecStart=/usr/bin/tvheadend -c /etc/tvheadend -f -p ${PID_DIR}/tvheadend.pid -C
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/user.conf b/user.conf
new file mode 100644
index 000000000000..39108edae836
--- /dev/null
+++ b/user.conf
@@ -0,0 +1,2 @@
+u tvheadend - "TVHeadend user" /var/lib/tvheadend
+m tvheadend video \ No newline at end of file